net-libs/webkit-gtk: cmake syntax is -DRUBY_EXECUTABLE, not RUBY
authorAlexandre Rostovtsev <tetromino@gentoo.org>
Sun, 13 Sep 2015 17:08:31 +0000 (13:08 -0400)
committerAlexandre Rostovtsev <tetromino@gentoo.org>
Sun, 13 Sep 2015 17:09:11 +0000 (13:09 -0400)
Package-Manager: portage-2.2.20.1

net-libs/webkit-gtk/webkit-gtk-2.6.6.ebuild
net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild

index 0f23ff9e944f9b3d9abe6e057c363c2cc91a2373..c4d72b73f93d4b7654c401cbae2780293ffe69f2 100644 (file)
@@ -172,13 +172,13 @@ src_configure() {
        local ruby_interpreter=""
 
        if has_version "virtual/rubygems[ruby_targets_ruby22]"; then
-               ruby_interpreter="RUBY=$(type -P ruby22)"
+               ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby22)"
        elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
-               ruby_interpreter="RUBY=$(type -P ruby21)"
+               ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby21)"
        elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
-               ruby_interpreter="RUBY=$(type -P ruby20)"
+               ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby20)"
        else
-               ruby_interpreter="RUBY=$(type -P ruby19)"
+               ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby19)"
        fi
 
        # TODO: Check Web Audio support
index ae110a9df26507ffaffe11b7218dc2c14d6660d5..bdd69c138218e9ed741f30139aa801795ba85460 100644 (file)
@@ -184,13 +184,13 @@ src_configure() {
        local ruby_interpreter=""
 
        if has_version "virtual/rubygems[ruby_targets_ruby22]"; then
-               ruby_interpreter="RUBY=$(type -P ruby22)"
+               ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby22)"
        elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
-               ruby_interpreter="RUBY=$(type -P ruby21)"
+               ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby21)"
        elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
-               ruby_interpreter="RUBY=$(type -P ruby20)"
+               ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby20)"
        else
-               ruby_interpreter="RUBY=$(type -P ruby19)"
+               ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby19)"
        fi
 
        # TODO: Check Web Audio support