dev-java/oracle-jre-bin: Version bump
authorJames Le Cuirot <chewi@gentoo.org>
Mon, 31 Aug 2015 22:12:46 +0000 (23:12 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 31 Aug 2015 22:43:08 +0000 (23:43 +0100)
Package-Manager: portage-2.2.20.1

dev-java/oracle-jre-bin/Manifest
dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.60.ebuild [new file with mode: 0644]

index 0fc4983594bcbe66cd34e5bc952a06e530842235..2a7c94a94018344a799539fe3fda69a967df2eab 100644 (file)
@@ -4,3 +4,5 @@ DIST jre-7u80-linux-i586.tar.gz 48558751 SHA256 b773aef1458a4adde03af62f8163c7e4
 DIST jre-7u80-linux-x64.tar.gz 47110223 SHA256 4c01efd0d8e80bb6e2f324ec3408ce64f066d4506c7ec93a491f615a4523f4f3 SHA512 e61e78ab1be0313690e8ab8d6cbae7366dd78aa4716f47c8908178196b658b94ee318dd04043965a72c34d8ef5c1cb4902afaa2188e76eb944256f090339107d WHIRLPOOL 1af7417b327402abaf4074445f051924de8b19810668890e089b66a488dddfc7f50cdd96a012130a591940338177164f66c83caf54c5d6d370be27d119a907fe
 DIST jre-8u51-linux-i586.tar.gz 65731094 SHA256 e59a6fc88e1fc62167be684ffd5de90f5d31f1c7b7e6361dde24b45afeaa8d3a SHA512 6b459f70c1bc4007a0e10e89682c5c33601b795f6693eda0836e49b9e248229e109947232aef7b9d15b38f92931a134bc96833408e44572bf3f3b2da301ad275 WHIRLPOOL dca9c6d3f68917561d1bc84fb9d33ba01907d57eee1487c7e080989a6b89332a4f8e198717b8c4fe992c71d6715aa0e058bb02bd9b90ed8a7055cbc1747e4311
 DIST jre-8u51-linux-x64.tar.gz 63861111 SHA256 25c2146b4ff1a12a9449589f8372f7f67cb63d6f6ad2b7f9ec92181cd3a31cee SHA512 7b3c8be7ba4014041e86b2dd597d027285185f9e8a484110bea589d73e4e35a9d709d57198610f466ea05ef8ea4b7e696f1fc844a60511d0ba111f666de5cf44 WHIRLPOOL 1472b32649afbed578eaf1b31006a2020bd217a3f75b9b7d7bc2fd8c32bcd422dfd46e7d11e2e5e34904a1f5cc0bd03885cb0c1515ccd63985ca974a6d61eddb
+DIST jre-8u60-linux-i586.tar.gz 73863653 SHA256 8e05fa8bf73937d5e63ae80583f1e33858f0ef6be23701fd3b0070ea7af4d93a SHA512 bc267a77afe86d0a685e724e75db914a55570ceb3e6b4845b51cbef35f6dc38f387cfc58e1539236d8857f035d45ede51e651ee87f49ca540818f79ded4e373a WHIRLPOOL bc8fafe1a6b81beb1a3a8893bbbbc1d3d3d1359f98c3dc94e1f3c391fec5d188cea565febd0266152408a9dccd53ee3519ab88d8fbddf40cdffd27f856db231f
+DIST jre-8u60-linux-x64.tar.gz 71680110 SHA256 49dadecd043152b3b448288a35a4ee6f3845ce6395734bacc1eae340dff3cbf5 SHA512 80dc232dd1ab770ccb5c267cd528fdb47546eeb08795d8eb8a5088aed536151855d07350e5a47bbd8404afc86857ab784ecc419802ebc41860cc71560fdb2c5e WHIRLPOOL 5d51d6f7ecdf59e0a897726954c13777f9678f2c511cb5367f8524a879ef33596ad869252b2663d6a1761fb98e7aaf5617aa379de2298f5507132b65053318a0
diff --git a/dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.60.ebuild b/dev-java/oracle-jre-bin/oracle-jre-bin-1.8.0.60.ebuild
new file mode 100644 (file)
index 0000000..b6ecede
--- /dev/null
@@ -0,0 +1,230 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils java-vm-2 prefix versionator
+
+# This URIs need updating when bumping!
+JRE_URI="http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html"
+JCE_URI="http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html"
+
+if [[ "$(get_version_component_range 4)" == 0 ]] ; then
+       S_PV="$(get_version_component_range 1-3)"
+else
+       MY_PV_EXT="u$(get_version_component_range 4)"
+       S_PV="$(get_version_component_range 1-4)"
+fi
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+
+AT_amd64="jre-${MY_PV}-linux-x64.tar.gz"
+AT_x86="jre-${MY_PV}-linux-i586.tar.gz"
+
+JCE_DIR="UnlimitedJCEPolicyJDK8"
+JCE_FILE="jce_policy-8.zip"
+
+DESCRIPTION="Oracle's Java SE Runtime Environment"
+HOMEPAGE="http://www.oracle.com/technetwork/java/javase/"
+SRC_URI="
+       amd64? ( ${AT_amd64} )
+       x86? ( ${AT_x86} )
+       jce? ( ${JCE_FILE} )"
+
+LICENSE="Oracle-BCLA-JavaSE"
+SLOT="1.8"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa +awt cups +fontconfig javafx jce nsplugin pax_kernel selinux"
+
+RESTRICT="fetch preserve-libs strip"
+QA_PREBUILT="*"
+
+# NOTES:
+#
+# * cups is dlopened.
+#
+# * libpng is also dlopened but only by libsplashscreen, which isn't
+#   important, so we can exclude that.
+#
+# * We still need to work out the exact AWT and JavaFX dependencies
+#   under MacOS. It doesn't appear to use many, if any, of the
+#   dependencies below.
+#
+RDEPEND="!x64-macos? (
+               awt? (
+                       x11-libs/libX11
+                       x11-libs/libXext
+                       x11-libs/libXi
+                       x11-libs/libXrender
+               )
+               javafx? (
+                       dev-libs/glib:2
+                       dev-libs/libxml2:2
+                       dev-libs/libxslt
+                       media-libs/freetype:2
+                       x11-libs/cairo
+                       x11-libs/gtk+:2
+                       x11-libs/libX11
+                       x11-libs/libXtst
+                       x11-libs/libXxf86vm
+                       x11-libs/pango
+                       virtual/opengl
+               )
+       )
+       alsa? ( media-libs/alsa-lib )
+       cups? ( net-print/cups )
+       fontconfig? ( media-libs/fontconfig:1.0 )
+       !prefix? ( sys-libs/glibc:* )
+       selinux? ( sec-policy/selinux-java )"
+
+# A PaX header isn't created by scanelf so depend on paxctl to avoid
+# fallback marking. See bug #427642.
+DEPEND="jce? ( app-arch/unzip )
+       pax_kernel? ( sys-apps/paxctl )"
+
+S="${WORKDIR}/jre"
+
+pkg_nofetch() {
+       local AT_ARCH="AT_${ARCH}"
+       local AT="${!AT_ARCH}"
+
+       einfo "Please download '${AT}' from:"
+       einfo "'${JRE_URI}'"
+       einfo "and move it to '${DISTDIR}'"
+
+       if use jce; then
+               einfo "Also download '${JCE_FILE}' from:"
+               einfo "'${JCE_URI}'"
+               einfo "and move it to '${DISTDIR}'"
+       fi
+
+       einfo
+       einfo "If the above mentioned urls do not point to the correct version anymore,"
+       einfo "please download the files from Oracle's java download archive:"
+       einfo
+       einfo "   http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html#jre-${MY_PV}-oth-JPR"
+       einfo
+
+}
+
+src_unpack() {
+       default
+
+       # Upstream is changing their versioning scheme every release around 1.8.0.*;
+       # to stop having to change it over and over again, just wildcard match and
+       # live a happy life instead of trying to get this new jre1.8.0_05 to work.
+       mv "${WORKDIR}"/jre* "${S}" || die
+}
+
+src_prepare() {
+       if use jce ; then
+               mv "${WORKDIR}"/${JCE_DIR} lib/security/ || die
+       fi
+}
+
+src_install() {
+       local dest="/opt/${P}"
+       local ddest="${ED}${dest#/}"
+
+       # Create files used as storage for system preferences.
+       mkdir .systemPrefs || die
+       touch .systemPrefs/.system.lock || die
+       touch .systemPrefs/.systemRootModFile || die
+
+       if ! use alsa ; then
+               rm -vf lib/*/libjsoundalsa.* || die
+       fi
+
+       if ! use awt ; then
+               rm -vf lib/*/lib*{[jx]awt,splashscreen}* \
+                  bin/{javaws,policytool} || die
+       fi
+
+       if ! use javafx ; then
+               rm -vf lib/*/lib*{decora,fx,glass,prism}* \
+                  lib/*/libgstreamer-lite.* lib/{,ext/}*fx* || die
+       fi
+
+       if ! use nsplugin ; then
+               rm -vf lib/*/libnpjp2.* || die
+       else
+               local nsplugin=$(echo lib/*/libnpjp2.*)
+       fi
+
+       # Even though plugins linked against multiple ffmpeg versions are
+       # provided, they generally lag behind what Gentoo has available.
+       rm -vf lib/*/libavplugin* || die
+
+       dodoc COPYRIGHT
+       dodir "${dest}"
+       cp -pPR bin lib man "${ddest}" || die
+
+       if use jce ; then
+               dodir ${dest}/lib/security/strong-jce
+               mv "${ddest}"/lib/security/US_export_policy.jar \
+                       "${ddest}"/lib/security/strong-jce || die
+               mv "${ddest}"/lib/security/local_policy.jar \
+                       "${ddest}"/lib/security/strong-jce || die
+               dosym "${dest}"/lib/security/${JCE_DIR}/US_export_policy.jar \
+                       "${dest}"/lib/security/US_export_policy.jar
+               dosym "${dest}"/lib/security/${JCE_DIR}/local_policy.jar \
+                       "${dest}"/lib/security/local_policy.jar
+       fi
+
+       if use nsplugin ; then
+               install_mozilla_plugin "${dest}/${nsplugin}"
+       fi
+
+       # Install desktop file for the Java Control Panel.
+       # Using ${PN}-${SLOT} to prevent file collision with jre and or other slots.
+       # make_desktop_entry can't be used as ${P} would end up in filename.
+       newicon lib/desktop/icons/hicolor/48x48/apps/sun-jcontrol.png \
+               sun-jcontrol-${PN}-${SLOT}.png || die
+       sed -e "s#Name=.*#Name=Java Control Panel for Oracle JRE ${SLOT}#" \
+               -e "s#Exec=.*#Exec=/opt/${P}/bin/jcontrol#" \
+               -e "s#Icon=.*#Icon=sun-jcontrol-${PN}-${SLOT}#" \
+               -e "s#Application;##" \
+               -e "/Encoding/d" \
+               lib/desktop/applications/sun_java.desktop > \
+               "${T}"/jcontrol-${PN}-${SLOT}.desktop || die
+       domenu "${T}"/jcontrol-${PN}-${SLOT}.desktop
+
+       # Prune all fontconfig files so libfontconfig will be used and only install
+       # a Gentoo specific one if fontconfig is disabled.
+       # http://docs.oracle.com/javase/8/docs/technotes/guides/intl/fontconfig.html
+       rm "${ddest}"/lib/fontconfig.* || die
+       if ! use fontconfig ; then
+               cp "${FILESDIR}"/fontconfig.Gentoo.properties "${T}"/fontconfig.properties || die
+               eprefixify "${T}"/fontconfig.properties
+               insinto "${dest}"/lib/
+               doins "${T}"/fontconfig.properties
+       fi
+
+       # This needs to be done before CDS - #215225
+       java-vm_set-pax-markings "${ddest}"
+
+       # see bug #207282
+       einfo "Creating the Class Data Sharing archives"
+       case ${ARCH} in
+               arm|ia64)
+                       ${ddest}/bin/java -client -Xshare:dump || die
+                       ;;
+               x86)
+                       ${ddest}/bin/java -client -Xshare:dump || die
+                       # limit heap size for large memory on x86 #467518
+                       # this is a workaround and shouldn't be needed.
+                       ${ddest}/bin/java -server -Xms64m -Xmx64m -Xshare:dump || die
+                       ;;
+               *)
+                       ${ddest}/bin/java -server -Xshare:dump || die
+                       ;;
+       esac
+
+       # Remove empty dirs we might have copied.
+       find "${D}" -type d -empty -exec rmdir -v {} + || die
+
+       set_java_env
+       java-vm_revdep-mask
+       java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}