media-libs/gegl: Use upstream CPU detection patch
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 14 Nov 2019 15:48:43 +0000 (16:48 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 14 Nov 2019 15:59:19 +0000 (16:59 +0100)
Bug: https://bugs.gentoo.org/698744
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
media-libs/gegl/files/gegl-0.4.18-arch.patch [deleted file]
media-libs/gegl/files/gegl-0.4.18-meson_cpu_detection.patch [new file with mode: 0644]
media-libs/gegl/gegl-0.4.18.ebuild

diff --git a/media-libs/gegl/files/gegl-0.4.18-arch.patch b/media-libs/gegl/files/gegl-0.4.18-arch.patch
deleted file mode 100644 (file)
index 57bfaf4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -88,8 +88,6 @@
-   have_ppc = true
-   config.set10('ARCH_PPC',    true)
-   config.set10('ARCH_PPC64',  true)
--else
--  error('Unknown host architecture')
- endif
- ################################################################################
diff --git a/media-libs/gegl/files/gegl-0.4.18-meson_cpu_detection.patch b/media-libs/gegl/files/gegl-0.4.18-meson_cpu_detection.patch
new file mode 100644 (file)
index 0000000..7f6b362
--- /dev/null
@@ -0,0 +1,51 @@
+From 6bcf95fd0f32cf5e8b1ddbe17b14d9ad049bded8 Mon Sep 17 00:00:00 2001
+From: Christoph Reiter <reiter.christoph@gmail.com>
+Date: Sun, 27 Oct 2019 14:10:08 +0100
+Subject: [PATCH] meson: fix cpu detection
+
+Use host_machine.cpu_family() instead of cpu(). Only the former
+provides a stable/defined set of values.
+
+Also don't error out on some arches for no good reason.
+
+This fixes the build on 32bit Windows.
+---
+ meson.build | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index af133a0f1..540498921 100644
+--- a/meson.build
++++ b/meson.build
+@@ -73,23 +73,21 @@ if os_osx and cc.get_id() != 'clang'
+ endif
+-host_cpu = host_machine.cpu()
+-if   host_cpu.startswith('i') and host_cpu.endswith('86')
++host_cpu_family = host_machine.cpu_family()
++if   host_cpu_family == 'x86'
+   have_x86 = true
+   config.set10('ARCH_X86',    true)
+-elif host_cpu == 'x86_64'
++elif host_cpu_family == 'x86_64'
+   have_x86 = true
+   config.set10('ARCH_X86',    true)
+   config.set10('ARCH_X86_64', true)
+-elif host_cpu == 'ppc' or host_cpu == 'powerpc'
++elif host_cpu_family == 'ppc'
+   have_ppc = true
+   config.set10('ARCH_PPC',    true)
+-elif host_cpu == 'ppc64' or host_cpu == 'powerpc64'
++elif host_cpu_family == 'ppc64'
+   have_ppc = true
+   config.set10('ARCH_PPC',    true)
+   config.set10('ARCH_PPC64',  true)
+-else
+-  error('Unknown host architecture')
+ endif
+ ################################################################################
+-- 
+2.22.0
+
index 7de01528fc40d9cc60b372657809bd1842b8750e..f23c5220119d4a34df85ff1b21a27bb4b9dfc1eb 100644 (file)
@@ -80,7 +80,7 @@ DOCS=( AUTHORS docs/ChangeLog docs/NEWS.txt )
 PATCHES=(
        "${FILESDIR}"/${PN}-0.4.18-drop-failing-tests.patch
        "${FILESDIR}"/${PN}-0.4.18-program-suffix.patch
-       "${FILESDIR}"/${PN}-0.4.18-arch.patch
+       "${FILESDIR}"/${P}-meson_cpu_detection.patch
 )
 
 pkg_setup() {