net-misc/connman: new live ebuild with several changes
authorBen Kohler <bkohler@gentoo.org>
Tue, 28 Jan 2020 14:00:04 +0000 (08:00 -0600)
committerBen Kohler <bkohler@gentoo.org>
Tue, 28 Jan 2020 14:03:30 +0000 (08:03 -0600)
1) Switch firewall default from iptables to nftables
2) Sort IUSE & configure args
3) EAPI=7 conversion
4) Add WireGuard support

Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-misc/connman/connman-9999.ebuild [new file with mode: 0644]
net-misc/connman/metadata.xml

diff --git a/net-misc/connman/connman-9999.ebuild b/net-misc/connman/connman-9999.ebuild
new file mode 100644 (file)
index 0000000..937b54e
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+inherit autotools systemd tmpfiles
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/connman/connman.git"
+else
+       SRC_URI="https://www.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="bluetooth debug doc +ethernet examples iptables iwd l2tp networkmanager
++nftables ofono openconnect openvpn policykit pptp tools vpnc +wifi wireguard
+wispr"
+
+REQUIRED_USE="^^ ( iptables nftables )"
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-libs/glib-2.16
+       >=sys-apps/dbus-1.2.24
+       sys-libs/readline:0=
+       bluetooth? ( net-wireless/bluez )
+       iptables? ( >=net-firewall/iptables-1.4.8 )
+       iwd? ( net-wireless/iwd )
+       l2tp? ( net-dialup/xl2tpd )
+       nftables? (
+               >=net-libs/libnftnl-1.0.4:0=
+               >=net-libs/libmnl-1.0.0:0= )
+       ofono? ( net-misc/ofono )
+       openconnect? ( net-vpn/openconnect )
+       openvpn? ( net-vpn/openvpn )
+       policykit? ( sys-auth/polkit )
+       pptp? ( net-dialup/pptpclient )
+       vpnc? ( net-vpn/vpnc )
+       wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+       wireguard? ( >=net-libs/libmnl-1.0.0:0= )
+       wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+       >=sys-kernel/linux-headers-2.6.39"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --localstatedir=/var \
+               --with-systemdunitdir=$(systemd_get_systemunitdir) \
+               --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+               --enable-client \
+               --enable-datafiles \
+               --enable-loopback=builtin \
+               $(use_enable bluetooth bluetooth builtin) \
+               $(use_enable debug) \
+               $(use_enable ethernet ethernet builtin) \
+               $(use_enable examples test) \
+               $(use_enable iwd) \
+               $(use_enable l2tp l2tp builtin) \
+               $(use_enable networkmanager nmcompat) \
+               $(use_enable ofono ofono builtin) \
+               $(use_enable openconnect openconnect builtin) \
+               $(use_enable openvpn openvpn builtin) \
+               $(use_enable policykit polkit builtin) \
+               $(use_enable pptp pptp builtin) \
+               $(use_enable tools) \
+               $(use_enable vpnc vpnc builtin) \
+               $(use_enable wifi wifi builtin) \
+               $(use_enable wireguard) \
+               $(use_enable wispr wispr builtin) \
+               --with-firewall=$(usex iptables "iptables" "nftables" ) \
+               --disable-iospm \
+               --disable-hh2serial-gps
+}
+
+src_install() {
+       default
+       dobin client/connmanctl
+
+       if use doc; then
+               dodoc doc/*.txt
+       fi
+       keepdir /usr/lib/${PN}/scripts
+       keepdir /var/lib/${PN}
+       newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+       newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+       tmpfiles_process /usr/lib/tmpfiles.d/connman_resolvconf.conf
+}
index b6bed9600f0d59d31653c3d64ad7477888282ad0..a8e17b602a0e76cba1c4707e0ac7b5d5f3e89b95 100644 (file)
@@ -18,5 +18,6 @@
                <flag name="tools">Enable testing tools.</flag>
                <flag name="vpnc">Use <pkg>net-vpn/vpnc</pkg> for cisco VPN support.</flag>
                <flag name="wispr">Enable support for WISPr hotspot logins.</flag>
+               <flag name="wireguard">Enable WireGuard VPN support.</flag>
        </use>
 </pkgmetadata>