dev-python/denonavr: add Python 3.7, make tests more verbose
authorLouis Sautier <sbraz@gentoo.org>
Tue, 24 Jul 2018 23:02:37 +0000 (01:02 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Tue, 24 Jul 2018 23:02:43 +0000 (01:02 +0200)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

dev-python/denonavr/denonavr-0.7.4.ebuild

index 4a3aab11963958f8e791bd81b71d5cb2e192e942..6f32967db35f42307a703d04c5dc64f9a42d759d 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{4,5,6,7} )
 PYTHON_REQ_USE="xml(+)"
 
 inherit distutils-r1
@@ -29,5 +29,5 @@ DEPEND="
 "
 
 python_test() {
-       py.test || die "tests failed with ${EPYTHON}"
+       pytest -vv || die "tests failed with ${EPYTHON}"
 }