sys-apps/debianutils: Bump to version 4.8.6.2
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 12 Jul 2019 08:43:33 +0000 (10:43 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 12 Jul 2019 15:26:39 +0000 (17:26 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/debianutils/Manifest
sys-apps/debianutils/debianutils-4.8.6.2.ebuild [new file with mode: 0644]

index 1adbd31b09a5859f04968388529c9493fe5cd838..4b6d47bd460f54db21d081f92c4d16bda6100c3e 100644 (file)
@@ -1,3 +1,4 @@
 DIST debianutils_4.8.3.tar.xz 159292 BLAKE2B e655741f42594ff12b4f349331da57ec09073802c9778594619686c93fc3061cf5248ac8e9e2c1b391eb49dd572f3033b1db206ff43f373b17caf7f3c835111f SHA512 468b8f001c0338f166cbc2fe25079edc5feeaa38dce2f5c7e6724c691d6cb35f4843e987695e33ead557bb11887e78ff8a5e3e1f52a266a0f32fb978fa643897
 DIST debianutils_4.8.6.1.tar.xz 156604 BLAKE2B 100bc458609273eb94da46e267395fe4ea16e499805b0d5a29f6144b8b7d2198ccb47b2048cdb6d311014c7b0ac373283cf6034a773ddbd95121856eb0dcbf83 SHA512 158f024311b3de292bd20df966c0f61285c748597101cee61e81883e0032c1e6a4baccb5c231b28f00ce3afc58a4aaedd64a65641351974c37fdb5f4952b0d2a
+DIST debianutils_4.8.6.2.tar.xz 156704 BLAKE2B 9ab9625042e8167daa988fb161db0dad56327ce8acb29b774a771e988c2e49ed17fe7ef3ce594b9fab3ffdc0518864b83c9dead91603b92d6c297fe79529b8c4 SHA512 1110d0f42870848a8a29b7b52d304ed39ae7d08156da09268dada7464ae45abc1f35320a12f218f8ba9bb2f1d323737136c143ef17141feef1275056842789a2
 DIST debianutils_4.8.6.tar.xz 156532 BLAKE2B 2add390a0e38aa3d7103e09b3b65fa2b88c3965ca411c5789409454519791bccdb12d89b1bea4d07417f733d23d0662d4f510750ab404d7a4e8f20c2bd3d7ef4 SHA512 5913729cc3c56962e8939b71803258952df0d7204df8090a7504fbefc7f5d1da8e749d606fe23148ea3294909ef172bc1f4f821690169e861729caab70921a2f
diff --git a/sys-apps/debianutils/debianutils-4.8.6.2.ebuild b/sys-apps/debianutils/debianutils-4.8.6.2.ebuild
new file mode 100644 (file)
index 0000000..2b96aa3
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="https://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+IUSE="+installkernel static"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch )
+
+src_configure() {
+       use static && append-ldflags -static
+       default
+}
+
+src_install() {
+       into /
+       dobin tempfile run-parts
+       if use installkernel ; then
+               dosbin installkernel
+       fi
+
+       into /usr
+       dosbin savelog
+
+       doman tempfile.1 run-parts.8 savelog.8
+       use installkernel && doman installkernel.8
+       cd debian || die
+       dodoc changelog control
+       keepdir /etc/kernel/postinst.d
+}