x11-misc/slock: Version bump
authorCédric Krier <cedk@gentoo.org>
Tue, 6 Mar 2007 22:55:12 +0000 (22:55 +0000)
committerCédric Krier <cedk@gentoo.org>
Tue, 6 Mar 2007 22:55:12 +0000 (22:55 +0000)
Package-Manager: portage-2.1.2-r9

x11-misc/slock/ChangeLog
x11-misc/slock/files/digest-slock-0.5 [new file with mode: 0644]
x11-misc/slock/slock-0.5.ebuild [new file with mode: 0644]

index 79e353520171f54d1c788ac1e5d3a23a0e2eeac8..19ccf6e7dcb06aec9eb172782a7f9f6c49e83c4a 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for x11-misc/slock
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/slock/ChangeLog,v 1.3 2007/01/28 17:46:55 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slock/ChangeLog,v 1.4 2007/03/06 22:55:12 cedk Exp $
+
+*slock-0.5 (06 Mar 2007)
+
+  06 Mar 2007; Cedric Krier <cedk@gentoo.org> +slock-0.5.ebuild:
+  Version bump
 
   28 Jan 2007; Cedric Krier <cedk@gentoo.org> -slock-0.3.ebuild,
   slock-0.4.ebuild:
diff --git a/x11-misc/slock/files/digest-slock-0.5 b/x11-misc/slock/files/digest-slock-0.5
new file mode 100644 (file)
index 0000000..79918eb
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 f4297e143e95f4567924a67d1c79d3d8 slock-0.5.tar.gz 3451
+RMD160 901db21a287315a0641b26ed93053acba473a055 slock-0.5.tar.gz 3451
+SHA256 2a57efaf39c8ac61cdfd07b3187ba1d984ebefcc1a1633f4479e06e89ca7a01f slock-0.5.tar.gz 3451
diff --git a/x11-misc/slock/slock-0.5.ebuild b/x11-misc/slock/slock-0.5.ebuild
new file mode 100644 (file)
index 0000000..1b9d603
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/slock/slock-0.5.ebuild,v 1.1 2007/03/06 22:55:12 cedk Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="simple X screen locker"
+HOMEPAGE="http://tools.suckless.org/view.sh/x+tools"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       sed -i \
+               -e "s/.*strip.*//" \
+               Makefile || die "sed failed"
+
+       sed -i \
+               -e "s/CFLAGS = -Os/CFLAGS +=/" \
+               -e "s/LDFLAGS =/LDFLAGS +=/" \
+               config.mk || die "sed failed"
+}
+
+src_compile() {
+       append-ldflags "-Wl,-z,now"
+       emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+       dodoc README
+}