app-emacs/vm: Fix compilation (bug #554542)
authorSebastian Pipping <sping@gentoo.org>
Thu, 13 Aug 2015 22:20:25 +0000 (00:20 +0200)
committerSebastian Pipping <sping@gentoo.org>
Thu, 13 Aug 2015 22:23:49 +0000 (00:23 +0200)
Patch from
https://launchpadlibrarian.net/140342636/emacs-vm-8.1.2-texinfo5.patch
https://bugs.launchpad.net/vm/8.2.x/+bug/1181584

Signed-off-by: Sebastian Pipping <sping@gentoo.org>
app-emacs/vm/files/vm-8.1.2-texinfo-5.patch [new file with mode: 0644]
app-emacs/vm/vm-8.1.2.ebuild

diff --git a/app-emacs/vm/files/vm-8.1.2-texinfo-5.patch b/app-emacs/vm/files/vm-8.1.2-texinfo-5.patch
new file mode 100644 (file)
index 0000000..0283e19
--- /dev/null
@@ -0,0 +1,59 @@
+diff -up emacs-vm-8.1.2/info/vm.texinfo.texinfo5 emacs-vm-8.1.2/info/vm.texinfo
+--- emacs-vm-8.1.2/info/vm.texinfo.texinfo5    2012-03-05 18:43:21.000000000 +0100
++++ emacs-vm-8.1.2/info/vm.texinfo     2013-05-19 00:05:10.000000000 +0200
+@@ -783,7 +783,8 @@ following formats:
+ @example
+ ``pop:@var{HOST}:@var{PORT}:@var{AUTH}:@var{USER}:@var{PASSWORD}''
+-``imap:@var{HOST}:@var{PORT}:@var{MAILBOX}:@var{AUTH}:@var{USER}:@var{PASSWORD}''@end example
++``imap:@var{HOST}:@var{PORT}:@var{MAILBOX}:@var{AUTH}:@var{USER}:@var{PASSWORD}''
++@end example
+ @noindent Remote mailboxes accessed by VM in this fashion are referred
+ to as @dfn{server folders} (and @dfn{POP folders} or @dfn{IMAP
+@@ -996,8 +997,7 @@ The variable's value should be an associ
+  ((@var{IMAPDROP} @var{NAME}) ...)
+ @end example
+-@var{IMAPDROP} is an IMAP maildrop specification (@ref{maildrop
+-  specification}). 
++@var{IMAPDROP} is an IMAP maildrop specification (@ref{maildrop specification}).
+ @var{NAME} is a string that should give a less cumbersome name that you
+ will use to refer to this maildrop when using @code{vm-visit-imap-folder}.
+@@ -2342,7 +2342,7 @@ MIME encode it as necessary.
+ * MIME preview::        Previewing a MIME message before sending.
+ @end menu
+-@node MIME attachments, MIME characters, MIME Composition, MIME Composition, 
++@node MIME attachments, MIME characters, MIME Composition, MIME Composition
+ @unnumberedsec MIME attachments
+ @kindex C-c C-a
+@@ -3328,13 +3328,15 @@ The fifth is `f' or ` ', for messages fi
+ The sixth is `w' or ` ', for messages written.
+ @*
+ The seventh is `e' or ` ', for messages that have been edited.
++@vindex vm-summary-attachment-indicator
+ @item P
+ indicator for a message with attachments.
+-The variable @vindex vm-summary-attachment-indicator
++The variable
+ @code{vm-summary-attachment-indicator} is the inserted string, by default a @code{$}.
++@vindex vm-summary-postponed-indicator
+ @item p
+ indicator for a postponed message. 
+-The variable @vindex vm-summary-postponed-indicator
++The variable
+ @code{vm-summary-postponed-indicator} is the inserted string, by default a @code{P}.
+ @item c
+ number of characters in message (ignoring headers)
+@@ -4588,7 +4590,7 @@ The project code base is maintained at t
+ @uref{http://launchpad.net/vm}.  The ``VM Development Team'' can be
+ reached here using the email address @code{vm@@launchpad.net}.
+-@unnumberedsubsec Savannah project site
++@unnumberedsec Savannah project site
+ The changes made in each of the releases is described in the @samp{NEWS}
+ file, which can be found in the source code repository.  The changes made
index 5213633069fc4af4c16790f5453e5ca544e7100b..c341eec1c10237f4c98f31c9b6f116427c1d70d6 100644 (file)
@@ -30,6 +30,7 @@ src_prepare() {
                elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
                epatch "${FILESDIR}/${PN}-8.0-no-pcrisis.patch"
        fi
+       epatch "${FILESDIR}/${P}-texinfo-5.patch"
 }
 
 src_configure() {