dev-java/sablecc: Convert to java-pkg-simple.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 4 Apr 2016 09:00:56 +0000 (09:00 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 4 Apr 2016 09:49:46 +0000 (09:49 +0000)
--straight-to-stable because the current stable version is broken.

Package-Manager: portage-2.2.26

dev-java/sablecc/sablecc-3.7-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/sablecc/sablecc-3.7-r1.ebuild b/dev-java/sablecc/sablecc-3.7-r1.ebuild
new file mode 100644 (file)
index 0000000..4892847
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java based compiler / parser generator"
+HOMEPAGE="http://www.sablecc.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+       >=virtual/jre-1.6"
+
+DEPEND="
+       >=virtual/jdk-1.6
+       source? ( app-arch/zip )"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+       java-pkg_clean
+}
+
+src_install() {
+       java-pkg-simple_src_install
+       java-pkg_dolauncher "${PN}" --main org.sablecc.sablecc.SableCC
+       dodoc AUTHORS THANKS
+       dohtml README.html
+}