app-admin/puppet: fix patch for puppet 6.4.1
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 20 Apr 2019 08:17:57 +0000 (03:17 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 20 Apr 2019 08:18:54 +0000 (03:18 -0500)
Fixes: https://bugs.gentoo.org/683836

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/puppet/files/puppet-fix-tests-6.4.1.patch [new file with mode: 0644]
app-admin/puppet/puppet-6.4.1.ebuild

diff --git a/app-admin/puppet/files/puppet-fix-tests-6.4.1.patch b/app-admin/puppet/files/puppet-fix-tests-6.4.1.patch
new file mode 100644 (file)
index 0000000..6b7b5b4
--- /dev/null
@@ -0,0 +1,18 @@
+--- spec/unit/network/http/api/indirected_routes_spec.rb       2018-09-17 19:36:56.000000000 -0500
++++ spec/unit/network/http/api/indirected_routes_spec.rb       2018-09-19 10:52:35.841614932 -0500
+@@ -144,15 +144,6 @@
+       handler.uri2indirection("GET", uri_escaped, params)
+     end
+-    it "when the environment is unknown should remove :environment from params passed to check_authorization and therefore fail" do
+-      expect(handler).to receive(:check_authorization).with(anything,
+-                                                            anything,
+-                                                            excluding(:environment))
+-      expect(lambda { handler.uri2indirection("GET",
+-                                              "#{master_url_prefix}/node/bar",
+-                                              {:environment => 'bogus'}) }).to raise_error(not_found_error)
+-    end
+-
+     it "should not URI unescape the indirection key as passed through to a call to check_authorization" do
+       expect(handler).to receive(:check_authorization).with(anything, anything, hash_including(environment: be_a(Puppet::Node::Environment).and(have_attributes(name: :env))))
index 1d12aee25d2c3a396d46382b9601c7366cac7f94..0fa5d710120186e71ee70371f677f7dbeb4ec3eb 100644 (file)
@@ -67,7 +67,7 @@ all_ruby_prepare() {
        rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
 
        # can't be run within portage.
-       epatch "${FILESDIR}/puppet-fix-tests-6.0.0.patch"
+       epatch "${FILESDIR}/puppet-fix-tests-6.4.1.patch"
 
        # fix systemd path
        epatch "${FILESDIR}/puppet-systemd.patch"