Adding masked snapshot for testing. Adds support for wxGTK-2.6, Seamonkey,
authorRyan Hill <rhill@gentoo.org>
Tue, 2 Jan 2007 09:01:35 +0000 (09:01 +0000)
committerRyan Hill <rhill@gentoo.org>
Tue, 2 Jan 2007 09:01:35 +0000 (09:01 +0000)
Firefox 2.0. May cause blindness. Removed crusty 0.5.4 ebuild.
Package-Manager: portage-2.1.2_rc4-r4

x11-libs/wxmozilla/ChangeLog
x11-libs/wxmozilla/files/digest-wxmozilla-0.5.7_pre20070102 [new file with mode: 0644]
x11-libs/wxmozilla/metadata.xml
x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild [new file with mode: 0644]

index 857184ce1a82c5b6751195eb10b3a5b85eed19cc..77eb490ae800151013adc04aef51d1696bca6496 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for x11-libs/wxmozilla
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/ChangeLog,v 1.9 2006/12/31 23:12:39 dirtyepic Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/ChangeLog,v 1.10 2007/01/02 09:01:35 dirtyepic Exp $
+
+*wxmozilla-0.5.7_pre20070102 (02 Jan 2007)
+
+  02 Jan 2007; Ryan Hill <dirtyepic@gentoo.org> metadata.xml,
+  -wxmozilla-0.5.4.ebuild, +wxmozilla-0.5.7_pre20070102.ebuild:
+  Adding masked snapshot for testing. Adds support for wxGTK-2.6, Seamonkey,
+  Firefox 2.0. May cause blindness. Removed crusty 0.5.4 ebuild.
 
   31 Dec 2006; Ryan Hill <dirtyepic@gentoo.org> -wxmozilla-0.5.3.ebuild:
   Remove old ebuild.
diff --git a/x11-libs/wxmozilla/files/digest-wxmozilla-0.5.7_pre20070102 b/x11-libs/wxmozilla/files/digest-wxmozilla-0.5.7_pre20070102
new file mode 100644 (file)
index 0000000..a5b8c3a
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 5e55cc942faf5ca67e71b045b17a041a wxmozilla-0.5.7_pre20070102.tar.gz 549104
+RMD160 528c15ae76fa465c484b0da3af11c00e021187b3 wxmozilla-0.5.7_pre20070102.tar.gz 549104
+SHA256 c9c48c2b476d911703fef8ecfab354b98740350e94954b7240db3601403e19f4 wxmozilla-0.5.7_pre20070102.tar.gz 549104
index f1dd0cd2050087863ccde247297f0015f926fef3..aea9855d3885475ab6c062da1fdd030e7920986d 100644 (file)
@@ -1,5 +1,8 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<herd>wxwindows</herd>
+       <herd>wxwindows</herd>
+       <maintainer>
+               <email>wxwindows@gentoo.org</email>
+       </maintainer>
 </pkgmetadata>
diff --git a/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild b/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild
new file mode 100644 (file)
index 0000000..b220b04
--- /dev/null
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxmozilla/wxmozilla-0.5.7_pre20070102.ebuild,v 1.1 2007/01/02 09:01:35 dirtyepic Exp $
+
+inherit eutils wxwidgets
+
+IUSE="doc firefox python"
+
+DESCRIPTION="Mozilla widget for wxWindows"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://wxmozilla.sourceforge.net/"
+
+DEPEND="
+       =x11-libs/wxGTK-2.6*
+       firefox? ( >=www-client/mozilla-firefox-2.0 )
+       !firefox?       ( >=www-client/seamonkey-1.0.0 )
+       python? ( dev-lang/python
+                       >=dev-python/wxpython-2.6.3 )"
+
+SLOT="0"
+LICENSE="wxWinLL-3"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/wxMozilla"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+}
+
+src_compile() {
+
+       # Current Problems:
+       #   -can't find wx-config without the funky configure option
+       #       -can't find wxpython
+       #               configure runs:
+       #                       wxpyvername=`$PYTHON -c "from wx.build.config import getExtraPath; print getExtraPath(addOpts=1)"
+       #               python replies:
+       #                       sh: wx-config: command not found
+       #                       sh: wx-config: command not found
+       #                       sh: wx-config: command not found
+       #                       sh: wx-config: command not found
+       #                       sh: wx-config: command not found
+
+       # Currently Working:
+       #
+       #       USE="-python" builds against seamonkey-1.0.7
+       #   USE="python" builds against seamonkey-1.0.7 but i'm not sure everything's
+       #       installed correctly.
+
+       # Currently Testing:
+       #       FF 2.0
+
+       WX_GTK_VER="2.6"
+       need-wxwidgets unicode
+
+       if use firefox; then
+               myconf="--enable-firefox --disable-seamonkey"
+       else
+               myconf="--disable-firefox --enable-seamonkey"
+       fi
+
+       econf \
+               $(use_enable python) \
+               --disable-gtktest \
+               --with-wx-config=wx-config-2.6 \
+               ${myconf} \
+               || die "configure failed"
+
+       emake || die "make failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "install failed"
+
+       if use doc; then
+               dodoc README
+               newdoc demo/main.cpp example.cpp
+               use python && dodoc wxPython/demo/*.py
+       fi
+}