games-misc/opengfx: Bump to version 0.5.5
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 26 Mar 2019 14:15:25 +0000 (15:15 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 26 Mar 2019 14:15:44 +0000 (15:15 +0100)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
games-misc/opengfx/Manifest
games-misc/opengfx/files/opengfx-0.5.5-Makefile.patch [new file with mode: 0644]
games-misc/opengfx/opengfx-0.5.5.ebuild [new file with mode: 0644]

index 829d62e6fc8830fe7e2d9551d2661c9bf367ef8e..cb8f5b3a92a87aaf1c417ff0a274380c555b6455 100644 (file)
@@ -1 +1,2 @@
 DIST opengfx-0.5.4-source.tar.xz 9638204 BLAKE2B bff7e5f7f72b62584c280ce2af2ad53df40027a7075ea5858a53f45a71be07db480cf61a603fc8e5df69b8c7d73284bf92e430a3fe130ae34ad1a921d8603925 SHA512 42f8438c747b42a77cf9d86c5da60ce3ce84ed347d714c345f3871806f9e35f2ed4729b445e0ee319f3e2edd53458dfbaad5ca42e389c3a2e800bce19223cdb1
+DIST opengfx-0.5.5-source.tar.xz 9639584 BLAKE2B 49af829802adf3756e89728697ea796b98422bd0e314cd21d34910f8f7428963c2d4799a933e861ae344a2e83dd748289bbe501bccb77aba647b484ed07de376 SHA512 952fb52e19bd790e335a9df0f11fa29b2fc570b49903419904956cc65883adde93d432160b16682366ab8b973b7852d2d30f574f1840f6fbd082e1addbe5bfe8
diff --git a/games-misc/opengfx/files/opengfx-0.5.5-Makefile.patch b/games-misc/opengfx/files/opengfx-0.5.5-Makefile.patch
new file mode 100644 (file)
index 0000000..dca9615
--- /dev/null
@@ -0,0 +1,22 @@
+--- opengfx-0.5.5-source/Makefile
++++ opengfx-0.5.5-source/Makefile
+@@ -99,8 +99,8 @@
+ AWK            ?= awk
+ GREP           ?= grep
+ PYTHON         ?= python
+-UNIX2DOS       ?= $(shell which unix2dos)
+-UNIX2DOS_FLAGS ?= $(shell [ -n $(UNIX2DOS) ] && $(UNIX2DOS) -q --version 2>/dev/null && echo "-q" || echo "")
++UNIX2DOS       ?= $(shell which unix2dos 2>/dev/null)
++UNIX2DOS_FLAGS ?= $(shell [ -n $(UNIX2DOS) ] && $(UNIX2DOS) -q --version 2>/dev/null >&2 && echo "-q" || echo "")
+ # Graphics processing
+ GIMP           ?= gimp
+@@ -719,7 +719,7 @@
+       $(_E)
+ endif
+       $(_E) "Release:"
+-      $(_E) "bananas:     Upload bundle to BaNaNaS
++      $(_E) "bananas:     Upload bundle to BaNaNaS"
+       $(_E)
+       $(_E) "Valid command line variables are:"
+       $(_E) "Helper programmes:"
diff --git a/games-misc/opengfx/opengfx-0.5.5.ebuild b/games-misc/opengfx/opengfx-0.5.5.ebuild
new file mode 100644 (file)
index 0000000..dc39acc
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.4.0
+       games-util/grfcodec"
+RDEPEND=""
+
+S="${WORKDIR}/${P}-source"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-0.5.5-Makefile.patch"
+)
+
+src_compile() {
+       emake GIMP=""  help  # print out the env to make bug reports better
+       emake GIMP="" _V="" bundle_tar
+}
+
+src_install() {
+       insinto "/usr/share/games/openttd/data/"
+       doins *.grf opengfx.obg
+       dodoc docs/{changelog.txt,readme.txt}
+}