app-text/hyperestraier: fix configure
authorAkinori Hattori <hattya@gentoo.org>
Tue, 12 May 2020 13:54:15 +0000 (22:54 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Tue, 12 May 2020 13:55:03 +0000 (22:55 +0900)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-text/hyperestraier/files/hyperestraier-configure.patch

index 4e747d9c754b53b00e003150f24ea1f4871f9a7f..0daee36183c63f4dfee7eac8777ab2cc242488e1 100644 (file)
@@ -1,3 +1,13 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -67,6 +67,7 @@
+ SKLIBS = @MYSKLIBS@
+ APPLIBS = @MYAPPLIBS@
+ LDENV = LD_RUN_PATH=/lib:/usr/lib:$(MYLIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@:.
++AR = @AR@
+ RUNENV = LD_LIBRARY_PATH=.:/lib:/usr/lib:$(MYLIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
+ MYPOSTCMD = @MYPOSTCMD@
 --- a/configure.in
 +++ b/configure.in
 @@ -24,24 +24,6 @@
    enables="$enables (debug)"
    stable="yes"
  fi
-@@ -187,19 +169,20 @@
+@@ -180,26 +161,28 @@
+   then
+     MYCFLAGS="-Wall -fPIC -fsigned-char -O1"
+   fi
+-  if gcc --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
++  if $CC --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
+   then
+     MYCFLAGS="-Wall -fPIC -fsigned-char -O1"
+   fi
  fi
++AC_CHECK_TOOL(AR, ar)
  
  # Underlying libraries
 +PKG_PROG_PKG_CONFIG
  
  
  #================================================================
+@@ -134,7 +112,7 @@
+ then
+   MYCFLAGS="-Wall -fPIC -fsigned-char -O1"
+ fi
+-if gcc --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
++if $CC --version | egrep -i '^2\.(8|9)' > /dev/null 2>&1
+ then
+   MYCFLAGS="-Wall -fPIC -fsigned-char -O1"
+ fi
 @@ -158,7 +136,7 @@
  AC_CHECK_LIB(lzo2, main)
  AC_CHECK_LIB(bz2, main)