version bump
authorCaleb Tennis <caleb@gentoo.org>
Tue, 13 Mar 2007 10:41:21 +0000 (10:41 +0000)
committerCaleb Tennis <caleb@gentoo.org>
Tue, 13 Mar 2007 10:41:21 +0000 (10:41 +0000)
Package-Manager: portage-2.1.2.1

dev-lang/ruby/ChangeLog
dev-lang/ruby/files/digest-ruby-1.8.5_p35 [new file with mode: 0644]
dev-lang/ruby/files/digest-ruby-1.8.6 [new file with mode: 0644]
dev-lang/ruby/ruby-1.8.5_p35.ebuild [new file with mode: 0644]
dev-lang/ruby/ruby-1.8.6.ebuild [new file with mode: 0644]

index bb59952672141fbf52c2751f2a43abf0f67cac56..781ed63147c1a49c62a773599b191722b4d930d6 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-lang/ruby
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.260 2007/03/13 10:37:05 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.261 2007/03/13 10:41:21 caleb Exp $
+
+*ruby-1.8.6 (13 Mar 2007)
+
+  13 Mar 2007; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.6.ebuild:
+  version bump
 
 *ruby-1.8.5_p35 (13 Mar 2007)
 
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.5_p35 b/dev-lang/ruby/files/digest-ruby-1.8.5_p35
new file mode 100644 (file)
index 0000000..4b973a9
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 dcaa0b3608990791a5348e94b2f427d5 onigd2_5_7.tar.gz 215529
+RMD160 43cf52af1243acf21932690307ed7b0c81ff2771 onigd2_5_7.tar.gz 215529
+SHA256 205b2857d77efc4caa3b98eaf91fd1cc8b8722b497df933d1fbd23f7a5186549 onigd2_5_7.tar.gz 215529
+MD5 fe413bf114e16b0cd596d869743e9d35 ruby-1.8.5-p35.tar.gz 4522314
+RMD160 8a87fb77ce5eab0a663431a7ad689d48cd9ca06c ruby-1.8.5-p35.tar.gz 4522314
+SHA256 4d937d5c51e95b4f5c881e334c1c3f69c8e894deac1024ed7c9911c4f78548f0 ruby-1.8.5-p35.tar.gz 4522314
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.6 b/dev-lang/ruby/files/digest-ruby-1.8.6
new file mode 100644 (file)
index 0000000..a77335f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 23d2494aa94e7ae1ecbbb8c5e1507683 ruby-1.8.6.tar.gz 4589394
+RMD160 a1ad902bb1311233cd3cf9db52ab2ec076a709f5 ruby-1.8.6.tar.gz 4589394
+SHA256 3ef37fb961d04471a1aef2c8079d6fab09932e3281d79859d5cd5d426bde0868 ruby-1.8.6.tar.gz 4589394
diff --git a/dev-lang/ruby/ruby-1.8.5_p35.ebuild b/dev-lang/ruby/ruby-1.8.5_p35.ebuild
new file mode 100644 (file)
index 0000000..6f5a7a9
--- /dev/null
@@ -0,0 +1,141 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5_p35.ebuild,v 1.1 2007/03/13 10:37:05 caleb Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+ONIGURUMA="onigd2_5_7"
+
+inherit flag-o-matic alternatives eutils multilib autotools versionator
+
+MY_P="${P/_p/-p}"
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${MY_P}.tar.gz
+       cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug socks5 tk cjk doc threads examples ipv6"
+RESTRICT="confcache"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+       >=sys-libs/readline-4.1
+       >=sys-libs/ncurses-5.2
+       socks5? ( >=net-proxy/dante-1.1.13 )
+       tk? ( dev-lang/tk )
+       >=dev-ruby/ruby-config-0.3.1
+       !=dev-lang/ruby-cvs-1.8*
+       !dev-ruby/rdoc
+       !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+       unpack ${A}
+
+       if use cjk ; then
+               einfo "Applying ${ONIGURUMA}"
+               pushd ${WORKDIR}/oniguruma
+#              epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
+               econf --with-rubydir=${S} || die "econf failed"
+               MY_PV=$(get_version_component_range 1-2)
+               make ${MY_PV/./}
+               popd
+       fi
+
+       cd "${S}"
+
+       # Fix a hardcoded lib path in configure script
+       sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+               configure.in || die "sed failed"
+
+       eautoreconf
+}
+
+src_compile() {
+       # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+       filter-flags -fomit-frame-pointer
+       # In many places aliasing rules are broken; play it safe
+       # as it's risky with newer compilers to leave it as it is.
+       append-flags -fno-strict-aliasing
+
+       # Socks support via dante
+       if use socks5 ; then
+               # Socks support can't be disabled as long as SOCKS_SERVER is
+               # set and socks library is present, so need to unset
+               # SOCKS_SERVER in that case.
+               unset SOCKS_SERVER
+       fi
+
+       # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+       if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+               append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+       fi
+
+       econf --program-suffix=${SLOT/./} --enable-shared \
+               $(use_enable socks5 socks) \
+               $(use_enable doc install-doc) \
+               $(use_enable threads pthread) \
+               $(use_enable ipv6 ipv6) \
+               $(use_enable debug debug) \
+               --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+               || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+src_install() {
+       LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
+       RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+       for d in $(find ${S}/ext -type d) ; do
+               RUBYLIB="${RUBYLIB}:$d"
+       done
+       export LD_LIBRARY_PATH RUBYLIB
+
+       make DESTDIR="${D}" install || die "make install failed"
+
+       MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+       keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+       keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+       if use doc; then
+               make DESTDIR="${D}" install-doc || die "make install-doc failed"
+       fi
+
+       if use examples; then
+               dodir ${ROOT}usr/share/doc/${PF}
+               cp -pPR sample ${D}/${ROOT}usr/share/doc/${PF}
+       fi
+
+       dosym libruby${SLOT/./}$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
+       dosym libruby${SLOT/./}$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
+
+       dodoc ChangeLog MANIFEST README* ToDo
+}
+
+pkg_postinst() {
+       ewarn
+       ewarn "Warning: Vim won't work if you've just updated ruby from"
+       ewarn "1.6.x to 1.8.x due to the library version change."
+       ewarn "In that case, you will need to remerge vim."
+       ewarn
+
+       if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+               ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+       fi
+       elog
+       elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+       elog
+}
+
+pkg_postrm() {
+       if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+               ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+       fi
+}
diff --git a/dev-lang/ruby/ruby-1.8.6.ebuild b/dev-lang/ruby/ruby-1.8.6.ebuild
new file mode 100644 (file)
index 0000000..2fd3f14
--- /dev/null
@@ -0,0 +1,138 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6.ebuild,v 1.1 2007/03/13 10:41:21 caleb Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+# A new version is needed for 1.8.6, currently disabled.
+ONIGURUMA="onigd2_5_8"
+
+inherit flag-o-matic alternatives eutils multilib autotools versionator
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/$(get_version_component_range 1-2)/${P}.tar.gz"
+#      cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+SLOT="1.8"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug socks5 tk doc threads examples ipv6" # cjk
+RESTRICT="confcache"
+
+RDEPEND=">=sys-libs/gdbm-1.8.0
+       >=sys-libs/readline-4.1
+       >=sys-libs/ncurses-5.2
+       socks5? ( >=net-proxy/dante-1.1.13 )
+       tk? ( dev-lang/tk )
+       >=dev-ruby/ruby-config-0.3.1
+       !=dev-lang/ruby-cvs-1.8*
+       !dev-ruby/rdoc
+       !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+src_unpack() {
+       unpack ${A}
+
+#      if use cjk ; then
+#              einfo "Applying ${ONIGURUMA}"
+#              pushd ${WORKDIR}/oniguruma
+##             epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
+#              econf --with-rubydir=${S} || die "econf failed"
+#              MY_PV=$(get_version_component_range 1-2)
+#              make ${MY_PV/./}
+#              popd
+#      fi
+
+       cd "${S}"
+
+       # Fix a hardcoded lib path in configure script
+       sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+               configure.in || die "sed failed"
+
+       eautoreconf
+}
+
+src_compile() {
+       # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+       filter-flags -fomit-frame-pointer
+       # In many places aliasing rules are broken; play it safe
+       # as it's risky with newer compilers to leave it as it is.
+       append-flags -fno-strict-aliasing
+
+       # Socks support via dante
+       if use socks5 ; then
+               # Socks support can't be disabled as long as SOCKS_SERVER is
+               # set and socks library is present, so need to unset
+               # SOCKS_SERVER in that case.
+               unset SOCKS_SERVER
+       fi
+
+       # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+       if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+               append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+       fi
+
+       econf --program-suffix=${SLOT/./} --enable-shared \
+               $(use_enable socks5 socks) \
+               $(use_enable doc install-doc) \
+               $(use_enable threads pthread) \
+               $(use_enable ipv6 ipv6) \
+               $(use_enable debug debug) \
+               --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+               || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+src_install() {
+       LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
+       RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+       for d in $(find ${S}/ext -type d) ; do
+               RUBYLIB="${RUBYLIB}:$d"
+       done
+       export LD_LIBRARY_PATH RUBYLIB
+
+       make DESTDIR="${D}" install || die "make install failed"
+
+       MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+       keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+       keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+       if use doc; then
+               make DESTDIR="${D}" install-doc || die "make install-doc failed"
+       fi
+
+       if use examples; then
+               dodir ${ROOT}usr/share/doc/${PF}
+               cp -pPR sample ${D}/${ROOT}usr/share/doc/${PF}
+       fi
+
+       dosym libruby${SLOT/./}$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
+       dosym libruby${SLOT/./}$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
+
+       dodoc ChangeLog NEWS README* ToDo
+}
+
+pkg_postinst() {
+       ewarn
+       ewarn "Warning: Vim won't work if you've just updated ruby from"
+       ewarn "1.6.x to 1.8.x due to the library version change."
+       ewarn "In that case, you will need to remerge vim."
+       ewarn
+
+       if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+               ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+       fi
+       elog
+       elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+       elog
+}
+
+pkg_postrm() {
+       if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+               ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+       fi
+}