Cleanup and fix #103889.
authorLuca Longinotti <chtekk@gentoo.org>
Mon, 5 Jun 2006 19:24:00 +0000 (19:24 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Mon, 5 Jun 2006 19:24:00 +0000 (19:24 +0000)
Package-Manager: portage-2.1_rc4-r2

net-www/mod_auth_kerb/ChangeLog
net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf
net-www/mod_auth_kerb/metadata.xml
net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild
net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild

index 0c5f2b306a3f38d918bffc9bebb75cb97d3ddc7f..7b1782b727dba533311ac8a92e18c323a8fb7957 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-www/mod_auth_kerb
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.13 2006/06/04 19:21:02 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.14 2006/06/05 19:24:00 chtekk Exp $
+
+  05 Jun 2006; Luca Longinotti <chtekk@gentoo.org>
+  -files/4.11-r1/11_mod_auth_kerb.conf, files/11_mod_auth_kerb.conf,
+  -files/mod_auth_kerb_register.patch, metadata.xml,
+  mod_auth_kerb-5.0_rc6.ebuild, mod_auth_kerb-5.0_rc7.ebuild:
+  Cleanup and fix bug #103889.
 
   04 Jun 2006; Michael Stewart <vericgar@gentoo.org>
   -mod_auth_kerb-4.11.ebuild, -mod_auth_kerb-4.11-r1.ebuild:
index 58e117c84fd057733509bdadaa10992127254127..0852c1148e986f9ae80e1e3976f7b266e49b44e3 100644 (file)
@@ -1,7 +1,14 @@
 <IfDefine AUTH_KERB>
-  <IfModule !mod_auth_kerb.c>
-    LoadModule kerb_auth_module    extramodules/mod_auth_kerb.so
-  </IfModule>
+       LoadModule auth_kerb_module    modules/mod_auth_kerb.so
 </IfDefine>
 
-#Place configuration directives here
+<IfModule mod_auth_kerb.c>
+       <Directory "/var/www/private">
+               AuthType Kerberos
+               AuthName "Kerberos Login"
+               # See the INSTALL file about howto create the keytab
+               Krb5Keytab conf/apache.keytab
+               KrbAuthRealms EXAMPLE.COM
+               Require valid-user
+       </Directory>
+</IfModule>
index ff5b6490402ee27b49f6e4b711d55247db5410d1..8f398d815b6c19f3767c5e0a321561dc9964d3c7 100644 (file)
@@ -1,8 +1,8 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<herd>apache</herd>
-<maintainer>
-  <email>apache-bugs@gentoo.org</email>
-</maintainer>
+       <herd>apache</herd>
+       <maintainer>
+               <email>apache-bugs@gentoo.org</email>
+       </maintainer>
 </pkgmetadata>
index 586432ad9e1fcd2cd116a1fe152bcfbea134f006..9db436ea798f12a48579c6fa94e730d622dedf28 100644 (file)
@@ -1,12 +1,12 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild,v 1.4 2006/05/13 21:30:08 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc6.ebuild,v 1.5 2006/06/05 19:24:00 chtekk Exp $
 
-MY_PV=${PV/_rc/-rc}
+MY_PV="${PV/_rc/-rc}"
 
 inherit eutils apache-module
 
-DESCRIPTION="An Apache2 authentication DSO using Kerberos"
+DESCRIPTION="An Apache2 authentication DSO using Kerberos."
 HOMEPAGE="http://modauthkerb.sourceforge.net/"
 SRC_URI="mirror://sourceforge/modauthkerb/${PN}-${MY_PV}.tar.gz"
 
@@ -15,26 +15,26 @@ KEYWORDS="x86"
 IUSE="apache2"
 SLOT="0"
 
-DEPEND="app-crypt/mit-krb5"
+DEPEND="virtual/krb5"
 RDEPEND=""
 
-APACHE1_MOD_CONF="4.11-r1/11_${PN}"
+APACHE1_MOD_CONF="11_${PN}"
 APACHE1_MOD_DEFINE="AUTH_KERB"
 
-APACHE2_MOD_CONF="4.11-r1/11_${PN}"
+APACHE2_MOD_CONF="11_${PN}"
 APACHE2_MOD_DEFINE="AUTH_KERB"
 
 DOCFILES="INSTALL README"
 
 need_apache
 
-S=${WORKDIR}/${PN}-${MY_PV}
+S="${WORKDIR}/${PN}-${MY_PV}"
 
 src_compile() {
-       if use apache2; then
-           CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+       if use apache2 ; then
+               CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
        else
-           CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+               CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
        fi
        emake || die "make failed"
 }
index 3c8d5d767b3a9f167f41137b2ac6af7088e95bd1..b552bcc12a13617affaf0d94495ccf19e5dc9db6 100644 (file)
@@ -1,12 +1,12 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild,v 1.1 2006/04/18 16:31:11 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-5.0_rc7.ebuild,v 1.2 2006/06/05 19:24:00 chtekk Exp $
 
-MY_PV=${PV/_rc/rc}
+MY_PV="${PV/_rc/rc}"
 
 inherit eutils apache-module
 
-DESCRIPTION="An Apache2 authentication DSO using Kerberos"
+DESCRIPTION="An Apache2 authentication DSO using Kerberos."
 HOMEPAGE="http://modauthkerb.sourceforge.net/"
 SRC_URI="mirror://sourceforge/modauthkerb/${PN}-${MY_PV}.tar.gz"
 
@@ -15,26 +15,26 @@ KEYWORDS="~x86"
 IUSE="apache2"
 SLOT="0"
 
-DEPEND="app-crypt/mit-krb5"
+DEPEND="virtual/krb5"
 RDEPEND=""
 
-APACHE1_MOD_CONF="4.11-r1/11_${PN}"
+APACHE1_MOD_CONF="11_${PN}"
 APACHE1_MOD_DEFINE="AUTH_KERB"
 
-APACHE2_MOD_CONF="4.11-r1/11_${PN}"
+APACHE2_MOD_CONF="11_${PN}"
 APACHE2_MOD_DEFINE="AUTH_KERB"
 
 DOCFILES="INSTALL README"
 
 need_apache
 
-S=${WORKDIR}/${PN}-${MY_PV}
+S="${WORKDIR}/${PN}-${MY_PV}"
 
 src_compile() {
-       if use apache2; then
-           CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+       if use apache2 ; then
+               CFLAGS="" APXS="${APXS2}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
        else
-           CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
+               CFLAGS="" APXS="${APXS}" econf --with-krb5=/usr --without-krb4 || die "econf failed"
        fi
        emake || die "make failed"
 }