dev-python/wand: new pkg, v0.6.1, ImageMagick binding for Python
authorLouis Sautier <sbraz@gentoo.org>
Sun, 17 May 2020 11:36:40 +0000 (13:36 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Sun, 17 May 2020 11:54:42 +0000 (13:54 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/wand/Manifest [new file with mode: 0644]
dev-python/wand/metadata.xml [new file with mode: 0644]
dev-python/wand/wand-0.6.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
new file mode 100644 (file)
index 0000000..bfe6776
--- /dev/null
@@ -0,0 +1 @@
+DIST Wand-0.6.1.tar.gz 10501178 BLAKE2B 76eb22363a20bc93fafae334a65917310cae82b0613b4b8b1eb749ef453268eb4413734ece7a39448d25782ce2ee8c63e71f9571707ec764851d82dbe5a6a6e4 SHA512 3edc4030130c1d03547d933f05eca4e9c9d10bdd527b1e41657a6b3f81d433da63fbbaddf63c726417f90335ac475508f1a467ee5e368eecb5cf9e94e79da9bf
diff --git a/dev-python/wand/metadata.xml b/dev-python/wand/metadata.xml
new file mode 100644 (file)
index 0000000..79a7ad6
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>sbraz@gentoo.org</email>
+               <name>Louis Sautier</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">Wand</remote-id>
+               <remote-id type="github">emcconville/wand</remote-id>
+               <bugs-to>https://github.com/emcconville/wand/issues</bugs-to>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/wand/wand-0.6.1.ebuild b/dev-python/wand/wand-0.6.1.ebuild
new file mode 100644 (file)
index 0000000..d4d05f1
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7,8} )
+
+inherit distutils-r1
+
+MY_P="${PN^}-${PV}"
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="http://wand-py.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-gfx/imagemagick"
+BDEPEND="
+       test? (
+               media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+               >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+       # PDF support is blocked by the default ImageMagick security policy
+       pytest -vv --skip-pdf || die "Tests fail with ${EPYTHON}"
+}