sys-kernel/genkernel: Fix breakage triggered by mount-boot update.
authorUlrich Müller <ulm@gentoo.org>
Fri, 13 Dec 2019 22:31:13 +0000 (23:31 +0100)
committerUlrich Müller <ulm@gentoo.org>
Fri, 13 Dec 2019 22:33:45 +0000 (23:33 +0100)
mount-boot_mount_boot_partition() was an internal and undocumented
function which shouldn't have been called, in the first place.

Delete it from pkg_postinst without replacement, because the relevant
checks in mount-boot_check_status will have been called already in
mount-boot_pkg_preinst.

Drop the call to mount-boot_pkg_postinst as well, because that
function is a no-op now.

Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
sys-kernel/genkernel/genkernel-4.0.0-r1.ebuild
sys-kernel/genkernel/genkernel-9999.ebuild

index c84640e954fd6ee86c00356aa778ce6528dc875a..9a9acff5358a806dfa59a593826688bf47a7362f 100644 (file)
@@ -234,7 +234,6 @@ pkg_postinst() {
                fi
        done
 
-       mount-boot_mount_boot_partition
        if [[ $(find /boot -name 'kernel-genkernel-*' 2>/dev/null | wc -l) -gt 0 ]] ; then
                ewarn ''
                ewarn 'Default kernel filename was changed from "kernel-genkernel-<ARCH>-<KV>"'
@@ -243,7 +242,6 @@ pkg_postinst() {
                ewarn 'built with genkernel before that name change, resulting in booting old'
                ewarn 'kernel when not paying attention on boot.'
        fi
-       mount-boot_pkg_postinst
 
        # Show special warning for users depending on remote unlock capabilities
        local gk_config="${EROOT}/etc/genkernel.conf"
index 6f69a282d07766ca2845b8e04771dd8940f7fcca..051e149a13d2cab879ff36bed918f1a50fd1ee8f 100644 (file)
@@ -232,7 +232,6 @@ pkg_postinst() {
                fi
        done
 
-       mount-boot_mount_boot_partition
        if [[ $(find /boot -name 'kernel-genkernel-*' 2>/dev/null | wc -l) -gt 0 ]] ; then
                ewarn ''
                ewarn 'Default kernel filename was changed from "kernel-genkernel-<ARCH>-<KV>"'
@@ -241,7 +240,6 @@ pkg_postinst() {
                ewarn 'built with genkernel before that name change, resulting in booting old'
                ewarn 'kernel when not paying attention on boot.'
        fi
-       mount-boot_pkg_postinst
 
        # Show special warning for users depending on remote unlock capabilities
        local gk_config="${EROOT}/etc/genkernel.conf"