media-libs/aubio: fix build with ffmpeg git master.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 16 Sep 2015 16:49:01 +0000 (18:49 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 16 Sep 2015 16:49:01 +0000 (18:49 +0200)
Package-Manager: portage-2.2.20.1

media-libs/aubio/aubio-0.4.1.ebuild
media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch [new file with mode: 0644]

index dfddfdbff94a43f8fe1ebb35b9b790980c2dc05d..3d8976b437ba758da5e0ed408217d8472ef4a920 100644 (file)
@@ -8,7 +8,7 @@ DISTUTILS_OPTIONAL=1
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE='threads(+)'
 
-inherit distutils-r1 waf-utils multilib
+inherit distutils-r1 waf-utils multilib eutils
 
 DESCRIPTION="Library for audio labelling"
 HOMEPAGE="http://aubio.org/"
@@ -39,6 +39,7 @@ PYTHON_SRC_DIR="${S}/python"
 src_prepare() {
        sed -i -e "s:\/lib:\/$(get_libdir):" src/wscript_build || die
        sed -i -e "s:doxygen:doxygen_disabled:" wscript || die
+       has_version '>=media-video/ffmpeg-2.8' && epatch "${FILESDIR}/${PN}-0.4.1-ffmpeg29.patch"
 }
 
 src_configure() {
diff --git a/media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch b/media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch
new file mode 100644 (file)
index 0000000..8656271
--- /dev/null
@@ -0,0 +1,22 @@
+Index: aubio-0.4.1/src/io/source_avcodec.c
+===================================================================
+--- aubio-0.4.1.orig/src/io/source_avcodec.c
++++ aubio-0.4.1/src/io/source_avcodec.c
+@@ -167,7 +167,7 @@ aubio_source_avcodec_t * new_aubio_sourc
+   }
+   AVFrame *avFrame = s->avFrame;
+-  avFrame = avcodec_alloc_frame();
++  avFrame = av_frame_alloc();
+   if (!avFrame) {
+     AUBIO_ERR("source_avcodec: Could not allocate frame for (%s)\n", s->path);
+   }
+@@ -415,7 +415,7 @@ void del_aubio_source_avcodec(aubio_sour
+   }
+   s->output = NULL;
+   if (s->avFrame != NULL) {
+-    avcodec_free_frame( &(s->avFrame) );
++    av_frame_free( &(s->avFrame) );
+   }
+   s->avFrame = NULL;
+   AUBIO_FREE(s);