media-sound/pithos: remove old and 9999
authorPatrick McLean <chutzpah@gentoo.org>
Sat, 2 May 2020 00:07:30 +0000 (17:07 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Sat, 2 May 2020 00:08:17 +0000 (17:08 -0700)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
media-sound/pithos/Manifest
media-sound/pithos/files/pithos-1.3.1-dont-try-to-update-icon-cache.patch [deleted file]
media-sound/pithos/pithos-1.3.1.ebuild [deleted file]
media-sound/pithos/pithos-9999.ebuild [deleted file]

index c6d92b6185b64792264c5767d49f834fd6c6e81f..1c11e496cf134c2cda9732aea0a5a98ab43632af 100644 (file)
@@ -1,2 +1 @@
-DIST pithos-1.3.1.tar.gz 119658 BLAKE2B 0d6e1c4e48a4beb1082f8788d4e016371660667dbe32ee925aa4b904f60a25e6664a94cefbc62dd9323a6e69338c03fc4080517e842102fd6eeca144f568c984 SHA512 c06715516992e4aa8bb3b200035ee10ef8dcec9491d32af0fb3f4e176d0ad5313a437f228747d5d716a29d2fe5b93ddd3704aa4fe674ce3be5a17eaad13b0da4
 DIST pithos-1.5.0.tar.gz 123047 BLAKE2B 6f93a41bdda6c3e9baf4d71248748d4e798f9426377fcdf5dded0bdbfec92278f98c215fe818b4d1fc5378d47275539d3a559f7b9d9d8c920f5218431b77c3b3 SHA512 eec2d2fa2fec7f87decc5934d4e1c2f8e11754cb1e042e749be102b27353811a6868636b51b8b9f88ad6f649a12347b82da98d81a476ad3b610ef1049155b657
diff --git a/media-sound/pithos/files/pithos-1.3.1-dont-try-to-update-icon-cache.patch b/media-sound/pithos/files/pithos-1.3.1-dont-try-to-update-icon-cache.patch
deleted file mode 100644 (file)
index 5e1b5da..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index 0c5e1cb..b413774 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -85,13 +85,11 @@ ubuntu_light_DATA = data/icons/ubuntu-mono-light/16x16/apps/io.github.Pithos-tra
- ubuntu_darkdir = $(datadir)/icons/ubuntu-mono-dark/16x16/apps
- ubuntu_dark_DATA = data/icons/ubuntu-mono-dark/16x16/apps/io.github.Pithos-tray.svg
--UPDATE_ICON_CACHE = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor || :
--
- install-data-hook:
--      $(UPDATE_ICON_CACHE);
-+      :;
- uninstall-hook:
--      $(UPDATE_ICON_CACHE);
-+      :;
- BUILT_SOURCES = pithos.gresource
- SUBDIRS = po
diff --git a/media-sound/pithos/pithos-1.3.1.ebuild b/media-sound/pithos/pithos-1.3.1.ebuild
deleted file mode 100644 (file)
index 102dfd5..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-inherit autotools gnome2-utils python-r1
-
-if [[ ${PV} =~ [9]{4,} ]]; then
-       inherit git-2
-       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="Pandora.com client for the GNOME desktop"
-HOMEPAGE="https://pithos.github.io/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="libnotify appindicator +keybinder"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="
-       ${PYTHON_DEPS}
-       dev-python/pylast[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
-       >=dev-python/pygobject-3.12[${PYTHON_USEDEP}]
-       dev-libs/appstream-glib[introspection]
-       x11-libs/pango[introspection]
-       media-libs/gstreamer:1.0[introspection]
-       media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
-       >=x11-libs/gtk+-3.14:3[introspection]
-       x11-themes/gnome-icon-theme-symbolic
-       libnotify? ( x11-libs/libnotify[introspection] )
-       appindicator? ( dev-libs/libappindicator:3[introspection] )
-       keybinder? ( dev-libs/keybinder:3[introspection] )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.3.1-dont-try-to-update-icon-cache.patch"
-)
-
-src_prepare() {
-       default
-       eautoreconf
-       python_copy_sources
-}
-
-pithos_src_configure() {
-       pushd "${BUILD_DIR}" || die
-       econf UPDATE_ICON_CACHE=":"
-       popd || die
-}
-
-src_configure() {
-       python_foreach_impl pithos_src_configure
-}
-
-pithos_src_compile() {
-       pushd "${BUILD_DIR}" || die
-       emake
-       popd || die
-}
-
-src_compile() {
-       python_foreach_impl pithos_src_compile
-}
-
-pithos_src_install() {
-       pushd "${BUILD_DIR}" || die
-       emake DESTDIR="${D}" install
-       python_doscript "${D}"/usr/bin/pithos
-       popd || die
-}
-
-src_install() {
-       python_foreach_impl pithos_src_install
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-       gnome2_schemas_savelist
-}
-pkg_postinst() {
-       gnome2_icon_cache_update
-       gnome2_schemas_update
-}
-pkg_postrm() {
-       gnome2_icon_cache_update
-       gnome2_schemas_update
-}
diff --git a/media-sound/pithos/pithos-9999.ebuild b/media-sound/pithos/pithos-9999.ebuild
deleted file mode 100644 (file)
index 1f2906d..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-inherit autotools gnome2-utils python-r1
-
-if [[ ${PV} =~ [9]{4,} ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-else
-       SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="Pandora.com client for the GNOME desktop"
-HOMEPAGE="https://pithos.github.io/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS=""
-IUSE="libnotify appindicator +keybinder"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND="
-       ${PYTHON_DEPS}
-       dev-python/pylast[${PYTHON_USEDEP}]
-       dev-python/dbus-python[${PYTHON_USEDEP}]
-       >=dev-python/pygobject-3.12[${PYTHON_USEDEP}]
-       dev-libs/appstream-glib[introspection]
-       x11-libs/pango[introspection]
-       media-libs/gstreamer:1.0[introspection]
-       media-plugins/gst-plugins-meta:1.0[aac,http,mp3]
-       >=x11-libs/gtk+-3.14:3[introspection]
-       x11-themes/gnome-icon-theme-symbolic
-       libnotify? ( x11-libs/libnotify[introspection] )
-       appindicator? ( dev-libs/libappindicator:3[introspection] )
-       keybinder? ( dev-libs/keybinder:3[introspection] )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.3.1-dont-try-to-update-icon-cache.patch"
-)
-
-src_prepare() {
-       default
-       eautoreconf
-       python_copy_sources
-}
-
-pithos_src_configure() {
-       pushd "${BUILD_DIR}" || die
-       econf UPDATE_ICON_CACHE=":"
-       popd || die
-}
-
-src_configure() {
-       python_foreach_impl pithos_src_configure
-}
-
-pithos_src_compile() {
-       pushd "${BUILD_DIR}" || die
-       emake
-       popd || die
-}
-
-src_compile() {
-       python_foreach_impl pithos_src_compile
-}
-
-pithos_src_install() {
-       pushd "${BUILD_DIR}" || die
-       emake DESTDIR="${D}" install
-       python_doscript "${D}"/usr/bin/pithos
-       popd || die
-}
-
-src_install() {
-       python_foreach_impl pithos_src_install
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-       gnome2_schemas_savelist
-}
-pkg_postinst() {
-       gnome2_icon_cache_update
-       gnome2_schemas_update
-}
-pkg_postrm() {
-       gnome2_icon_cache_update
-       gnome2_schemas_update
-}