app-admin/sudo: Synced live ebuild
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 11 Apr 2020 12:47:49 +0000 (14:47 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 11 Apr 2020 12:48:01 +0000 (14:48 +0200)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-admin/sudo/sudo-9999.ebuild

index f0df8a6c9e228dfd77f54714d8d89cd05536f2d2..cecc68448ea905f5b5584e45674c137e4ac8ab38 100644 (file)
@@ -30,10 +30,11 @@ fi
 # 3-clause BSD license
 LICENSE="ISC BSD"
 SLOT="0"
-IUSE="gcrypt ldap libressl nls offensive pam sasl +secure-path selinux +sendmail skey sssd system-digest"
+IUSE="gcrypt ldap libressl nls offensive pam sasl +secure-path selinux +sendmail skey ssl sssd"
 
 DEPEND="
        sys-libs/zlib:=
+       gcrypt? ( dev-libs/libgcrypt:= )
        ldap? (
                >=net-nds/openldap-2.1.30-r1
                sasl? (
@@ -44,14 +45,11 @@ DEPEND="
        pam? ( sys-libs/pam )
        sasl? ( dev-libs/cyrus-sasl )
        skey? ( >=sys-auth/skey-1.1.5-r1 )
-       sssd? ( sys-auth/sssd[sudo] )
-       system-digest? (
-               gcrypt? ( dev-libs/libgcrypt:= )
-               !gcrypt? (
-                       !libressl? ( dev-libs/openssl:0= )
-                       libressl? ( dev-libs/libressl:0= )
-               )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
        )
+       sssd? ( sys-auth/sssd[sudo] )
 "
 RDEPEND="
        ${DEPEND}
@@ -137,36 +135,34 @@ src_configure() {
        # until `make` time, so we have to use a full path here rather than
        # basing off other values.
        myeconfargs=(
-               --enable-zlib=system
+               # requires some python eclass
+               --disable-python
                --enable-tmpfiles.d="${EPREFIX}"/usr/lib/tmpfiles.d
+               --enable-zlib=system
                --with-editor="${EPREFIX}"/usr/libexec/editor
                --with-env-editor
                --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/sudo
                --with-rundir="${EPREFIX}"/run/sudo
-               $(use_with secure-path secure-path "${SECURE_PATH}")
                --with-vardir="${EPREFIX}"/var/db/sudo
                --without-linux-audit
                --without-opie
                $(use_enable gcrypt)
                $(use_enable nls)
                $(use_enable sasl)
+               $(use_enable ssl openssl)
+               $(use_with ldap)
+               $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo)
                $(use_with offensive insults)
                $(use_with offensive all-insults)
-               $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo)
-               $(use_with ldap)
                $(use_with pam)
-               $(use_with skey)
-               $(use_with sssd)
+               $(use_with pam pam-login)
+               $(use_with secure-path secure-path "${SECURE_PATH}")
                $(use_with selinux)
                $(use_with sendmail)
+               $(use_with skey)
+               $(use_with sssd)
        )
 
-       if use system-digest && ! use gcrypt; then
-               myeconfargs+=("--enable-openssl")
-       else
-               myeconfargs+=("--disable-openssl")
-       fi
-
        econf "${myeconfargs[@]}"
 }
 
@@ -209,7 +205,7 @@ src_install() {
 
        # Don't install into /run as that is a tmpfs most of the time
        # (bug #504854)
-       rm -rf "${ED}"/run
+       rm -rf "${ED}"/run || die
 
        find "${ED}" -type f -name "*.la" -delete || die #697812
 }