sci-libs/ceres-solver: Restrict non native X86 to supporting USE
authorJustin Lecher <jlec@gentoo.org>
Sun, 22 Jan 2017 10:20:27 +0000 (10:20 +0000)
committerJustin Lecher <jlec@gentoo.org>
Sun, 22 Jan 2017 10:21:14 +0000 (10:21 +0000)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=593954
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=596560
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=606776

Package-Manager: Portage-2.3.3, Repoman-2.3.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-libs/ceres-solver/ceres-solver-1.11.0.ebuild
sci-libs/ceres-solver/metadata.xml

index f027bf48b6b3f9e9f442875419746d654827a084..02c634f52a8d0a6d53925764a507bd2276af7a28 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -15,12 +15,12 @@ SRC_URI="${HOMEPAGE}/${P}.tar.gz"
 LICENSE="sparse? ( BSD ) !sparse? ( LGPL-2.1 ) cxsparse? ( BSD )"
 SLOT="0/1"
 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
 IUSE="cxsparse c++11 doc examples gflags lapack openmp +schur sparse test"
-REQUIRED_USE="test? ( gflags ) sparse? ( lapack )"
+
+REQUIRED_USE="test? ( gflags ) sparse? ( lapack ) abi_x86_32? ( !sparse !lapack )"
 
 RDEPEND="
-       dev-cpp/glog[gflags?]
+       dev-cpp/glog[gflags?,${MULTILIB_USEDEP}]
        cxsparse? ( sci-libs/cxsparse:0= )
        lapack? ( virtual/lapack )
        sparse? (
@@ -29,7 +29,8 @@ RDEPEND="
                sci-libs/ccolamd:0=
                sci-libs/cholmod:0=
                sci-libs/colamd:0=
-               sci-libs/spqr:0= )"
+               sci-libs/spqr:0=
+       )"
 
 DEPEND="${RDEPEND}
        dev-cpp/eigen:3
index e08063b30f267c6ca958af0bc0b67e7d05bfca0c..644a681b4140a80a3248c704829de0f857b2b14e 100644 (file)
@@ -1,11 +1,11 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer type="project">
-  <email>sci@gentoo.org</email>
-  <name>Gentoo Science Project</name>
-</maintainer>
-<longdescription lang="en">
+  <maintainer type="project">
+    <email>sci@gentoo.org</email>
+    <name>Gentoo Science Project</name>
+  </maintainer>
+  <longdescription lang="en">
   Ceres Solver is a portable C++ library that allows for
   modeling and solving large complicated nonlinear least squares
   problems. It features:
     * Iterative linear solvers for general sparse and bundle
       adjustment problems
 </longdescription>
-<use>
-  <flag name="cxsparse">Enable simple support for sparse matrix algebra from
+  <use>
+    <flag name="cxsparse">Enable simple support for sparse matrix algebra from
   <pkg>sci-libs/cxsparse</pkg> with no LAPACK dependencies</flag>
-  <flag name="schur">Enable fixed-size schur specializations (disable if
+    <flag name="schur">Enable fixed-size schur specializations (disable if
   binary size is an issue)</flag>
-  <flag name="sparse">Enable support for sparse matrix algebra with various
+    <flag name="sparse">Enable support for sparse matrix algebra with various
   packages from SuiteSparse</flag>
-  <flag name="gflags">Use <pkg>dev-cpp/gflags</pkg> for flag parsing</flag>
-  <flag name="protobuf">Use <pkg>dev-libs/protobuf</pkg> to encode structured data</flag>
-  <flag name="c++11">Build ceres-solver using the C++11 standard</flag>
-</use>
+    <flag name="gflags">Use <pkg>dev-cpp/gflags</pkg> for flag parsing</flag>
+    <flag name="protobuf">Use <pkg>dev-libs/protobuf</pkg> to encode structured data</flag>
+    <flag name="c++11">Build ceres-solver using the C++11 standard</flag>
+  </use>
 </pkgmetadata>