dev-ros/test_rosmaster: install the empty message.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 14:37:20 +0000 (15:37 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 14:47:00 +0000 (15:47 +0100)
Bug: https://bugs.gentoo.org/624804
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/test_rosmaster/files/empty.patch [new file with mode: 0644]
dev-ros/test_rosmaster/test_rosmaster-1.14.3-r1.ebuild

diff --git a/dev-ros/test_rosmaster/files/empty.patch b/dev-ros/test_rosmaster/files/empty.patch
new file mode 100644 (file)
index 0000000..8ec371c
--- /dev/null
@@ -0,0 +1,12 @@
+Index: test_rosmaster/CMakeLists.txt
+===================================================================
+--- test_rosmaster.orig/CMakeLists.txt
++++ test_rosmaster/CMakeLists.txt
+@@ -10,6 +10,7 @@ if(CATKIN_ENABLE_TESTING)
+     String.msg
+     Arrays.msg
+     CompositeA.msg CompositeB.msg Composite.msg
++    Empty.msg
+     Embed.msg Floats.msg Simple.msg
+     RosmsgA.msg
+     RosmsgB.msg
index 2eda0a57767c7818da5ab92b2c12f12bcd0c041e..3d61a62f82a87119a86f4f82f2cd6d5e09ac6937 100644 (file)
@@ -23,7 +23,7 @@ RDEPEND="dev-ros/rosgraph[${PYTHON_USEDEP}]
 DEPEND="${RDEPEND}
        test? ( dev-ros/roslib[${PYTHON_USEDEP}] )
 "
-PATCHES=( "${FILESDIR}/yaml.patch" )
+PATCHES=( "${FILESDIR}/yaml.patch" "${FILESDIR}/empty.patch" )
 
 mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )