app-portage/portage-utils: support LibreSSL
authorFabian Groffen <grobian@gentoo.org>
Thu, 6 Jun 2019 06:57:19 +0000 (08:57 +0200)
committerFabian Groffen <grobian@gentoo.org>
Thu, 6 Jun 2019 07:27:05 +0000 (09:27 +0200)
Bug: https://bugs.gentoo.org/687372
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-portage/portage-utils/portage-utils-0.80_pre20190530.ebuild
app-portage/portage-utils/portage-utils-9999.ebuild

index ab1bd1ffee16e0991ba220f4017444c7d4be543f..86a1c0df20a83b569b8ddcf98ba99aae8b0327ad 100644 (file)
@@ -10,7 +10,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="nls static openmp +qmanifest"
+IUSE="nls static openmp +qmanifest libressl"
 
 if [[ ${PV} == *9999 ]]; then
        inherit git-r3 autotools
@@ -33,7 +33,8 @@ DEPEND="${RDEPEND}
                        )
                )
                app-crypt/libb2
-               dev-libs/openssl:0=
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
                sys-libs/zlib
                app-crypt/gpgme
        )
index 25967bcab798616006e4ff413743672e86faf8ab..42e27f0ce8a1e8e251d9597efa1e52e655b86a01 100644 (file)
@@ -10,7 +10,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="nls static openmp +qmanifest"
+IUSE="nls static openmp +qmanifest libressl"
 
 if [[ ${PV} == *9999 ]]; then
        inherit git-r3 autotools
@@ -33,7 +33,8 @@ DEPEND="${RDEPEND}
                        )
                )
                app-crypt/libb2
-               dev-libs/openssl:0=
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
                sys-libs/zlib
                app-crypt/gpgme
        )