app-admin/mcelog: bump to 167
authorBen Kohler <bkohler@gentoo.org>
Sat, 14 Dec 2019 13:16:37 +0000 (07:16 -0600)
committerBen Kohler <bkohler@gentoo.org>
Sat, 14 Dec 2019 13:16:54 +0000 (07:16 -0600)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
app-admin/mcelog/Manifest
app-admin/mcelog/mcelog-167.ebuild [new file with mode: 0644]

index 95fbd33212e994c43bfe247b88f2360ded32c282..b63629aa227dde41c60cdd68e8e86f839eb05a87 100644 (file)
@@ -2,3 +2,4 @@ DIST mcelog-162.tar.gz 308347 BLAKE2B bd438e85ea793c6c5ce4d561f0400e91b101a010cc
 DIST mcelog-164.tar.gz 308393 BLAKE2B da1f425faa88eb8377eb11c3e13aa6fd4c0b4f4d3b02afc2fba8e4137979bb5619b075b0d0ecd80ec6059c9eb912376291e56e667bf7b838bd2f641c4a6c175f SHA512 10c8c580b10caa6d40c2a4887cb9e9ec07eb81a353d24a4d1a89ad8ec5cc29f7976c26335f077393794b060e62b5cbbe348c64567a3cf3fabc3ec5c3fe59da5a
 DIST mcelog-165.tar.gz 308405 BLAKE2B 8e6cf59bfa3a5c667c1b709f9c0c5c82f8710ff1aa7c5758c1573a2c832030bb31735f8dd5a53fab26745739cdfac3001cb7a752df579cf452874d19e9e7da65 SHA512 466a07a90679380783524854934d6d66cbc53474616de9141cd36dd2a3b757cacccf1db50c8d4cd54763cea63ac9c09daf6e27ccf3bcf17d62da7fc3396281eb
 DIST mcelog-166.tar.gz 312451 BLAKE2B 430630f6f693ae22961bae2381117dbb6d3bca228d6bdcbbe007d2a2681cda53f8c29cf18b98a47a88d36fd059e3e08aff5b9ad22243d7ce5083f5643768b0e6 SHA512 35514188cf4932b4ecffb8d8149534367a424adb76f03833d53d3c2a0dae2ca89de90d071e48ed67a17a8a70a67efc14aa186280e9145b7572887dccdf9a01af
+DIST mcelog-167.tar.gz 312512 BLAKE2B 5642a421149847bddc46e776932c0fcaab1e281904a6be4ff8a3254d9e292d5fb77e6fbd5097c7afe0b39eca2f2db1752cdf67714a8a3d2f836785ebde3c0c90 SHA512 0229df9a4772e916af79aa35cdbc644feff76870d87a8c3c6ce5d132cf8c98bc48ec48ba564496071cb803537d3504c84963639370d9aed11d23833b65b3b306
diff --git a/app-admin/mcelog/mcelog-167.ebuild b/app-admin/mcelog/mcelog-167.ebuild
new file mode 100644 (file)
index 0000000..557b542
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A tool to log and decode Machine Check Exceptions"
+HOMEPAGE="http://mcelog.org/"
+SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
+
+# TODO: add mce-inject to the tree to support test phase
+RESTRICT="test"
+
+pkg_pretend() {
+       if [[ ${MERGE_TYPE} != buildonly ]]; then
+               local CONFIG_CHECK="~X86_MCE"
+               kernel_is -ge 4 12 && CONFIG_CHECK+=" ~X86_MCELOG_LEGACY"
+               check_extra_config
+       fi
+}
+
+src_prepare() {
+       eapply "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
+               "${FILESDIR}"/${PN}-129-debugflags.patch
+       eapply_user
+       tc-export CC
+}
+
+src_install() {
+       default
+
+       insinto /etc/cron.daily
+       newins ${PN}.cron ${PN}
+
+       insinto /etc/logrotate.d/
+       newins ${PN}.logrotate ${PN}
+
+       newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
+       systemd_dounit "${FILESDIR}"/${PN}.service
+
+       dodoc *.pdf
+}
+
+pkg_postinst() {
+       einfo "The default configuration set is now installed in /etc/${PN}"
+       einfo "you might want to edit those files."
+       einfo
+       einfo "A sample cronjob is installed into /etc/cron.daily"
+       einfo "without executable bit (system service is the preferred method now)"
+}