app-shells/autojump: use newbashcomp
authorLukáš Poláček <lukas@ksp.sk>
Sun, 13 Sep 2015 10:07:40 +0000 (12:07 +0200)
committerLukáš Poláček <lukas@ksp.sk>
Sun, 13 Sep 2015 10:07:40 +0000 (12:07 +0200)
Also edit autojump.sh to use /usr/share instead of /usr/local/share

app-shells/autojump/autojump-22.2.4-r2.ebuild

index 6ae3def36b6805258e5191d2bc84490f167e7ccc..b485a21dcc395d407152de8a9eff70e05e9a4728 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 
 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
 
-inherit python-r1 vcs-snapshot
+inherit bash-completion-r1 python-r1 vcs-snapshot
 
 DESCRIPTION="change directory command that learns"
 HOMEPAGE="https://github.com/joelthelion/autojump"
@@ -24,6 +24,7 @@ DEPEND="test? ( dev-python/flake8 dev-python/tox )"
 
 src_prepare() {
        sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+               -e "s:/usr/local/share:/usr/share:" \
                -i bin/autojump.sh || die
 }
 
@@ -37,8 +38,8 @@ src_install() {
        insinto /etc/profile.d
        doins bin/${PN}.sh
 
+       newbashcomp bin/${PN}.bash ${PN}
        insinto /usr/share/"${PN}"/
-       doins bin/${PN}.bash
        doins bin/${PN}.zsh
        insinto /usr/share/zsh/site-functions
        doins bin/_j