media-video/vlc: update live ebuilds, migrate to CPU_FLAGS_PPC
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 16 Mar 2020 02:36:08 +0000 (19:36 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Wed, 18 Mar 2020 19:04:12 +0000 (12:04 -0700)
Acked-by: Andreas Sturmlechner <asturm@gentoo.org>
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
media-video/vlc/vlc-3.0.9999.ebuild
media-video/vlc/vlc-9999.ebuild

index 82a971bef8129a984b0faf1e4c7478a7d70161a0..46be52b9fc5b3388305f1155bccc6e41613f68eb 100644 (file)
@@ -29,7 +29,7 @@ HOMEPAGE="https://www.videolan.org/vlc/"
 LICENSE="LGPL-2.1 GPL-2"
 SLOT="0/5-9" # vlc - vlccore
 
-IUSE="a52 alsa altivec aom archive aribsub bidi bluray cddb chromaprint chromecast
+IUSE="a52 alsa aom archive aribsub bidi bluray cddb chromaprint chromecast
        dav1d dbus dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac
        fluidsynth fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate
        libass libav libcaca libnotify +libsamplerate libtar libtiger linsys lirc
@@ -37,7 +37,8 @@ IUSE="a52 alsa altivec aom archive aribsub bidi bluray cddb chromaprint chromeca
        nfs ogg omxil optimisememory opus png postproc projectm pulseaudio +qt5 rdp
        run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl svg taglib
        theora tremor truetype twolame udev upnp vaapi v4l vdpau vnc vorbis vpx wayland +X
-       x264 x265 xml zeroconf zvbi cpu_flags_arm_neon cpu_flags_x86_mmx cpu_flags_x86_sse
+       x264 x265 xml zeroconf zvbi cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_x86_mmx
+       cpu_flags_x86_sse
 "
 REQUIRED_USE="
        chromecast? ( encode )
@@ -281,7 +282,6 @@ src_configure() {
                --enable-vlc
                $(use_enable a52)
                $(use_enable alsa)
-               $(use_enable altivec)
                $(use_enable aom)
                $(use_enable archive)
                $(use_enable aribsub)
@@ -293,6 +293,7 @@ src_configure() {
                $(use_enable chromecast)
                $(use_enable chromecast microdns)
                $(use_enable cpu_flags_arm_neon neon)
+               $(use_enable cpu_flags_ppc_altivec altivec)
                $(use_enable cpu_flags_x86_mmx mmx)
                $(use_enable cpu_flags_x86_sse sse)
                $(use_enable dav1d)
index ace48d66459726ccb45169b462ba1f18c777ff17..87341a4212c997e708725b00cc0ea83c02ce3ea8 100644 (file)
@@ -29,7 +29,7 @@ HOMEPAGE="https://www.videolan.org/vlc/"
 LICENSE="LGPL-2.1 GPL-2"
 SLOT="0/12-9" # vlc - vlccore
 
-IUSE="a52 alsa altivec aom archive aribsub bidi bluray cddb chromaprint chromecast
+IUSE="a52 alsa aom archive aribsub bidi bluray cddb chromaprint chromecast
        dav1d dbus dc1394 debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac
        fluidsynth fontconfig +gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate kms
        libass libav libcaca libnotify libplacebo +libsamplerate libtar libtiger linsys lirc
@@ -37,7 +37,8 @@ IUSE="a52 alsa altivec aom archive aribsub bidi bluray cddb chromaprint chromeca
        nfs ogg omxil optimisememory opus png postproc projectm pulseaudio +qt5 rdp
        run-as-root samba sdl-image sftp shout sid skins soxr speex srt ssl svg taglib
        theora tremor truetype twolame udev upnp vaapi v4l vdpau vnc vorbis vpx wayland +X
-       x264 x265 xml zeroconf zvbi cpu_flags_arm_neon cpu_flags_x86_mmx cpu_flags_x86_sse
+       x264 x265 xml zeroconf zvbi cpu_flags_arm_neon cpu_flags_ppc_altivec cpu_flags_x86_mmx
+       cpu_flags_x86_sse
 "
 REQUIRED_USE="
        chromecast? ( encode )
@@ -283,7 +284,6 @@ src_configure() {
                --enable-vlc
                $(use_enable a52)
                $(use_enable alsa)
-               $(use_enable altivec)
                $(use_enable aom)
                $(use_enable archive)
                $(use_enable aribsub)
@@ -295,6 +295,7 @@ src_configure() {
                $(use_enable chromecast)
                $(use_enable chromecast microdns)
                $(use_enable cpu_flags_arm_neon neon)
+               $(use_enable cpu_flags_ppc_altivec altivec)
                $(use_enable cpu_flags_x86_mmx mmx)
                $(use_enable cpu_flags_x86_sse sse)
                $(use_enable dav1d)