dev-python/python-ceilometerclient: update to py37
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:05:31 +0000 (13:05 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:06:36 +0000 (13:06 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
RepoMan-Options: --force
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2-r2.ebuild [moved from dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2-r1.ebuild with 63% similarity]

similarity index 63%
rename from dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2-r1.ebuild
rename to dev-python/python-ceilometerclient/python-ceilometerclient-2.6.2-r2.ebuild
index e5fcd00d4b48b54a3ce81bb7c00b3b4308d80947..86d42367d4d352efef9a72dbe1836d692740e06e 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
 
 inherit distutils-r1
 
@@ -13,23 +13,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
-               >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
-               <dev-python/fixtures-2.0[${PYTHON_USEDEP}]
-               >=dev-python/mock-1.2[${PYTHON_USEDEP}]
-               >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
-               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
-       )"
+       ${CDEPEND}"
 RDEPEND="
        ${CDEPEND}
        >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
@@ -47,9 +35,3 @@ python_prepare_all() {
        sed -i '/^hacking/d' test-requirements.txt || die
        distutils-r1_python_prepare_all
 }
-
-python_test() {
-       testr init
-       testr run || die "tests failed under python2.7"
-       flake8 ceilometerclient/tests/ || die "run over tests folder by flake8 yielded error"
-}