sys-apps/cinit: port to EAPI=7
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 9 Feb 2020 11:34:51 +0000 (14:34 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 9 Feb 2020 11:35:58 +0000 (14:35 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sys-apps/cinit/cinit-0.2.1.ebuild

index c52fcc2f67389e26184662edbb9f7a913d36aaa8..252f62e217b93bf6c61028d2701413eed163bd11 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 inherit toolchain-funcs
 
@@ -17,6 +17,7 @@ IUSE="doc"
 src_prepare() {
        sed -i "/contrib+tools/d" Makefile || die
        sed -i "/^STRIP/s/strip.*/true/" Makefile.include || die
+       default
 }
 
 src_compile() {
@@ -31,7 +32,7 @@ src_compile() {
 
 src_install() {
        emake LD=$(tc-getCC) DESTDIR="${D}" install
-       rm -f "${D}"/sbin/{init,shutdown,reboot}
+       rm -f "${D}"/sbin/{init,shutdown,reboot} || die
        dodoc Changelog CHANGES CREDITS README TODO
        use doc && dodoc -r doc
 }