app-portage/gander: New package
authorMichał Górny <mgorny@gentoo.org>
Tue, 19 May 2020 11:16:51 +0000 (13:16 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 19 May 2020 11:19:28 +0000 (13:19 +0200)
Initial version of the statistic submission client for Goose.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/gander/Manifest [new file with mode: 0644]
app-portage/gander/gander-0.0.1.ebuild [new file with mode: 0644]
app-portage/gander/metadata.xml [new file with mode: 0644]

diff --git a/app-portage/gander/Manifest b/app-portage/gander/Manifest
new file mode 100644 (file)
index 0000000..a067728
--- /dev/null
@@ -0,0 +1 @@
+DIST gander-0.0.1.tar.gz 8882 BLAKE2B 29c25fedabff3936e13789ae31f2e06871cfe4eb31a0eed1d36150ec219e741d25ba1603d0151d026777c81dff8461a1c051e4c02bff2488d8b9d6888ebe9618 SHA512 d72b2fd92ddd646369f8eb16d73a67e7b793aa84109231365abebec3ab2e14a8c76bae301271ec1cc82850a71bcb217a72f969086554e6c850117b5492215d57
diff --git a/app-portage/gander/gander-0.0.1.ebuild b/app-portage/gander/gander-0.0.1.ebuild
new file mode 100644 (file)
index 0000000..e843e0c
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..8} )
+inherit distutils-r1
+
+DESCRIPTION="Statistic submission client for Goose (anser.gentoo.org)"
+HOMEPAGE="https://github.com/mgorny/gander/"
+SRC_URI="
+       https://github.com/mgorny/gander/archive/v${PV}.tar.gz
+               -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/requests[${PYTHON_USEDEP}]
+       sys-apps/portage[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? (
+               dev-python/responses[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest
+
+python_test() {
+       # Portage exports random configuration options *overriding* its own
+       # behavior into the build environment.
+       env -u PORTAGE_REPOSITORIES pytest -vv ||
+               die "Tests fail with ${EPYTHON}"
+}
diff --git a/app-portage/gander/metadata.xml b/app-portage/gander/metadata.xml
new file mode 100644 (file)
index 0000000..0319eec
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>mgorny@gentoo.org</email>
+               <name>Michał Górny</name>
+       </maintainer>
+</pkgmetadata>