app-arch/unzip: security cleanup (bug #691566)
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 26 Mar 2020 18:23:28 +0000 (19:23 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 26 Mar 2020 18:24:51 +0000 (19:24 +0100)
Bug: https://bugs.gentoo.org/691566
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-arch/unzip/Manifest
app-arch/unzip/unzip-6.0_p21-r2.ebuild [deleted file]

index 5f1282b23fcefa6846cd064409780bbb9eda1e94..dce593202f55c8042431567ed3a8c2c1ae9ce199 100644 (file)
@@ -1,3 +1,2 @@
 DIST unzip60.tar.gz 1376845 BLAKE2B 5016d300b4452018a391f4ebc03c6960c068df400a0407c0c60bd7bb5ec5012031f916d8b204a6149ba291c2c35beba40d9b43c76fc093026e79471329ab0e47 SHA512 0694e403ebc57b37218e00ec1a406cae5cc9c5b52b6798e0d4590840b6cdbf9ddc0d9471f67af783e960f8fa2e620394d51384257dca23d06bcd90224a80ce5d
-DIST unzip_6.0-21.debian.tar.xz 17740 BLAKE2B 098a84e5b05f819f9c8c6a6656fdb2359dfb5b93f63444e55347e0bef9735fa48bf1631a658a2cb6d0c604e7e740e47b57910d251b74e5df7c8b9468acfe55f4 SHA512 f7bce4156ac13c34da3f991df3ae88b0db99b0810c7f8904ea3ac666a4cb2788d7182056f2bbd82d7519d0e0ee31a10af47bee08f360ceb859e5fbfc6e15ef36
 DIST unzip_6.0-25.debian.tar.xz 23096 BLAKE2B 09cd89165c0354431fa0eb946bb8f8355fa09ef81cd3e3ea03e53ca7f465b323364204ffe11d8e58eeb5b46e40be598d4f709b621d163bfde09070b6847db2a6 SHA512 13c16db420fa4a34be3090a9acdd79b01320da40ac5aa89a9dfca03e64b914b28eb72aff3882d02a8197457bcb8eeb9473c998cf6920e511883c9289a949fb21
diff --git a/app-arch/unzip/unzip-6.0_p21-r2.ebuild b/app-arch/unzip/unzip-6.0_p21-r2.ebuild
deleted file mode 100644 (file)
index 3b19411..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils toolchain-funcs flag-o-matic
-
-MY_PV="${PV//.}"
-MY_PV="${MY_PV%_p*}"
-MY_P="${PN}${MY_PV}"
-
-DESCRIPTION="unzipper for pkzip-compressed files"
-HOMEPAGE="http://www.info-zip.org/"
-SRC_URI="mirror://sourceforge/infozip/${MY_P}.tar.gz
-       mirror://debian/pool/main/u/${PN}/${PN}_${PV/_p/-}.debian.tar.xz"
-
-LICENSE="Info-ZIP"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x86-linux"
-IUSE="bzip2 natspec unicode"
-
-DEPEND="bzip2? ( app-arch/bzip2 )
-       natspec? ( dev-libs/libnatspec )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
-       local deb="${WORKDIR}"/debian/patches
-       rm "${deb}"/02-this-is-debian-unzip.patch || die
-       eapply "${deb}"/*.patch
-
-       eapply "${FILESDIR}"/${PN}-6.0-no-exec-stack.patch
-       eapply "${FILESDIR}"/${PN}-6.0-format-security.patch
-       use natspec && eapply "${FILESDIR}/${PN}-6.0-natspec.patch" #275244
-       sed -i -r \
-               -e '/^CFLAGS/d' \
-               -e '/CFLAGS/s:-O[0-9]?:$(CFLAGS) $(CPPFLAGS):' \
-               -e '/^STRIP/s:=.*:=true:' \
-               -e "s:\<CC *= *\"?g?cc2?\"?\>:CC=\"$(tc-getCC)\":" \
-               -e "s:\<LD *= *\"?(g?cc2?|ld)\"?\>:LD=\"$(tc-getCC)\":" \
-               -e "s:\<AS *= *\"?(g?cc2?|as)\"?\>:AS=\"$(tc-getCC)\":" \
-               -e 's:LF2 = -s:LF2 = :' \
-               -e 's:LF = :LF = $(LDFLAGS) :' \
-               -e 's:SL = :SL = $(LDFLAGS) :' \
-               -e 's:FL = :FL = $(LDFLAGS) :' \
-               -e "/^#L_BZ2/s:^$(use bzip2 && echo .)::" \
-               -e 's:$(AS) :$(AS) $(ASFLAGS) :g' \
-               unix/Makefile \
-               || die "sed unix/Makefile failed"
-
-       # Delete bundled code to make sure we don't use it.
-       rm -r bzip2 || die
-
-       eapply_user
-}
-
-src_configure() {
-       case ${CHOST} in
-       i?86*-*linux*)       TARGET="linux_asm" ;;
-       *linux*)             TARGET="linux_noasm" ;;
-       i?86*-*bsd* | \
-       i?86*-dragonfly*)    TARGET="freebsd" ;; # mislabelled bsd with x86 asm
-       *bsd* | *dragonfly*) TARGET="bsd" ;;
-       *-darwin*)           TARGET="macosx" ;;
-       *-cygwin*)           TARGET="cygwin" ;;
-       *) die "Unknown target; please update the ebuild to handle ${CHOST}     " ;;
-       esac
-
-       [[ ${CHOST} == *linux* ]] && append-cppflags -DNO_LCHMOD
-       use bzip2 && append-cppflags -DUSE_BZIP2
-       use unicode && append-cppflags -DUNICODE_SUPPORT -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE -DUSE_ICONV_MAPPING
-       append-cppflags -DLARGE_FILE_SUPPORT #281473
-}
-
-src_compile() {
-       ASFLAGS="${ASFLAGS} $(get_abi_var CFLAGS)" \
-       emake -f unix/Makefile ${TARGET}
-}
-
-src_install() {
-       dobin unzip funzip unzipsfx unix/zipgrep
-       dosym unzip /usr/bin/zipinfo
-       doman man/*.1
-       dodoc BUGS History* README ToDo WHERE
-}