dev-haskell/text: drop USE=developer as it breaks API, bug #561100
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 24 Sep 2015 21:40:44 +0000 (22:40 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 24 Sep 2015 21:40:55 +0000 (22:40 +0100)
Reported-by: Paul Osmialowski
Bug: https://bugs.gentoo.org/561100

Package-Manager: portage-2.2.20

dev-haskell/text/text-1.2.1.3.ebuild

index 287dd53167d81c882734e7c5c05b85a750e20211..7b18429f811bf2deb6165ec07847043310ef4379 100644 (file)
@@ -4,7 +4,8 @@
 
 EAPI=5
 
-# ebuild generated by hackport 0.4.5.9999
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -developer
 
 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
 inherit haskell-cabal
@@ -16,7 +17,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0/${PV}"
 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="developer"
+IUSE=""
 
 RDEPEND="dev-haskell/binary:=[profile?]
        >=dev-lang/ghc-7.4.1:=
@@ -34,5 +35,5 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag developer developer)
+               --flag=-developer
 }