mail-client/roundcube: 1.4.4 version bump
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Thu, 30 Apr 2020 18:22:45 +0000 (14:22 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Fri, 8 May 2020 09:53:52 +0000 (05:53 -0400)
Closes: https://bugs.gentoo.org/720142
Closes: https://github.com/gentoo/gentoo/pull/15582
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Closes: https://github.com/gentoo/gentoo/pull/15582
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
mail-client/roundcube/Manifest
mail-client/roundcube/roundcube-1.4.4.ebuild [new file with mode: 0644]

index 7583d0ec34503c7704d4c2c75ed7cf908f187629..fcf158db2a9579235e2d5afa576868bd2f9b925a 100644 (file)
@@ -5,3 +5,4 @@ DIST roundcubemail-1.4.0-complete.tar.gz 6997256 BLAKE2B b19a2d049512ceb53b3844f
 DIST roundcubemail-1.4.1-complete.tar.gz 6998687 BLAKE2B ff33e512bb202d37d77ae2a4c7820f1061598bee1eb01bed5f15b25ad0e27c0cfe3611b44d451982491b702abcf6d7ae1bc88cbd303bc9a2573fc79efc54bec5 SHA512 0c8e09e93c86aad0f3e3a5a81c5e9ad8ab8aee101ae8ebb78d29556575db94a51a07cbf955ec79235425a961427b826ad27fae750b8eae785eedd195161dabed
 DIST roundcubemail-1.4.2-complete.tar.gz 7006013 BLAKE2B f92b94de3ce58cd145ce3d30875902d44410cb039176be5c2d09a23741b08405b21107b03a0ae302cfdf5a845a49cf044f13a09b582f291639648aac3b2f4c81 SHA512 3f705bc38b44a0b7ea3241b0222f607b040ec01c8ea400b6b6222fbe346570c5f3450e5a188bab99ea171481453eb3f5b1e7457070ace1144558ec662a4273bb
 DIST roundcubemail-1.4.3-complete.tar.gz 7028284 BLAKE2B c53efbee437960339c6e80a1fd2affff8ae8dfebd886cf029fc081d16c7874f0b6ea7fa03edb54276384dbf9d3948d84a6869f97cf3ce6bf27c52d50ba76ca56 SHA512 c65359473d08a46dbd42894c2758a46209491fc421ee58ab5b1c0d0d56e3fec8b2f43d01b18cb8934589cbee7e7abfda2c8efbf02b3521790d7b45ed6dc88a1e
+DIST roundcubemail-1.4.4-complete.tar.gz 7029864 BLAKE2B 2a6764a65c29e3deac6275c3dfd19ab2bee1f33ae1a7767561fcac25688bb8f3f7eeaee3eece20d2a6210aff18a5e493d0be709f4a3ae2ad4f3cfd9a1b124f06 SHA512 ddea321b5266c547f67c010147e9aa1457bea4802bec37f9e9d87e691bdc8df27f5c90cff8770de2458822160b85f7359f62742072ae1d642a040b9d88651519
diff --git a/mail-client/roundcube/roundcube-1.4.4.ebuild b/mail-client/roundcube/roundcube-1.4.4.ebuild
new file mode 100644 (file)
index 0000000..6d3b3ed
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+       ${DEPEND}
+       >=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+       virtual/httpd-php
+       change-password? (
+               dev-lang/php[sockets]
+       )
+       enigma? (
+               app-crypt/gnupg
+       )
+       mysql? (
+               || (
+                       dev-lang/php[mysql]
+                       dev-lang/php[mysqli]
+               )
+       )
+       spell? ( dev-lang/php[curl,spell] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       webapp_src_preinst
+
+       dodoc CHANGELOG INSTALL README.md UPGRADING
+
+       insinto "${MY_HTDOCSDIR}"
+       doins -r [[:lower:]]* SQL
+       doins .htaccess
+
+       webapp_serverowned "${MY_HTDOCSDIR}"/logs
+       webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+       webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+       webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+       webapp_src_install
+}
+
+pkg_postinst() {
+       webapp_pkg_postinst
+
+       if [[ -n ${REPLACING_VERSIONS} ]]; then
+               elog "You can review the post-upgrade instructions at:"
+               elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+       fi
+}