version bump: mainly bug fixes; adjusted DESCRIPTION; added adjusted configure patch...
authorChristian Faulhammer <fauli@gentoo.org>
Mon, 15 Jan 2007 10:13:43 +0000 (10:13 +0000)
committerChristian Faulhammer <fauli@gentoo.org>
Mon, 15 Jan 2007 10:13:43 +0000 (10:13 +0000)
Package-Manager: portage-2.1.1-r2

app-emacs/auctex/ChangeLog
app-emacs/auctex/auctex-11.84.ebuild [new file with mode: 0644]
app-emacs/auctex/files/auctex-11.84-configure.diff [new file with mode: 0644]
app-emacs/auctex/files/digest-auctex-11.84 [new file with mode: 0644]

index 8ca835456a2487457bbd602056df4f4c67137ec1..79cc1c20ae8b1f01f4a07f1de6112822484b85c5 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for app-emacs/auctex
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.49 2006/12/06 15:37:47 opfer Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/ChangeLog,v 1.50 2007/01/15 10:13:43 opfer Exp $
+
+*auctex-11.84 (15 Jan 2007)
+
+  15 Jan 2007; <fauli@gentoo.org> -files/auctex-11.54-configure.diff,
+  +files/auctex-11.84-configure.diff, +auctex-11.84.ebuild:
+  version bump: mainly bug fixes; adjusted DESCRIPTION; added adjusted
+  configure patch; removed stray patch
+  Thanks to Christian Schlotter <again@gmx.de> in bug #161923
 
   06 Dec 2006; Christian Faulhammer <opfer@gentoo.org> auctex-11.55.ebuild,
   auctex-11.82.ebuild, auctex-11.83.ebuild:
diff --git a/app-emacs/auctex/auctex-11.84.ebuild b/app-emacs/auctex/auctex-11.84.ebuild
new file mode 100644 (file)
index 0000000..f3f1050
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auctex/auctex-11.84.ebuild,v 1.1 2007/01/15 10:13:43 opfer Exp $
+
+inherit elisp eutils latex-package autotools
+
+DESCRIPTION="An extensible package that supports writing and formatting TeX files"
+HOMEPAGE="http://www.gnu.org/software/auctex/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="preview-latex"
+
+DEPEND="virtual/tetex
+       preview-latex? ( !dev-tex/preview-latex
+               app-text/dvipng
+               virtual/ghostscript )"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       # skip XEmacs detection. this is a workaround for emacs23
+       epatch "${FILESDIR}/${P}-configure.diff"
+}
+
+src_compile() {
+       # Don't install in the main tree, as this causes file collisions
+       # with app-text/tetex, see bug #155944
+       # Does no harm when used with USE=-preview-latex 
+       local PREVIEW_TEXMFDIR="${D}`kpsewhich -var-value=TEXMFSITE`"
+       mkdir -p "${PREVIEW_TEXMFDIR}"
+
+       econf --disable-build-dir-test \
+               --with-auto-dir="${D}/var/lib/auctex" \
+               --with-lispdir="${D}/usr/share/emacs/site-lisp" \
+               --with-texmf-dir="${PREVIEW_TEXMFDIR}" \
+               $(use_enable preview-latex preview) || die "econf failed"
+       emake || die
+}
+
+src_install() {
+       einstall || die
+       dosed ${SITELISP}/tex-site.el || die
+       elisp-site-file-install "${FILESDIR}/52auctex-gentoo.el"
+       if use preview-latex; then
+          elisp-site-file-install "${FILESDIR}/60auctex-gentoo.el"
+       fi
+       dodoc ChangeLog CHANGES README RELEASE TODO FAQ INSTALL*
+}
+
+pkg_postinst() {
+       # rebuild TeX-inputfiles-database
+       use preview-latex && latex-package_pkg_postinst
+       elisp-site-regen
+}
+
+pkg_postrm(){
+        use preview-latex && latex-package_pkg_postrm
+        elisp-site-regen
+}
diff --git a/app-emacs/auctex/files/auctex-11.84-configure.diff b/app-emacs/auctex/files/auctex-11.84-configure.diff
new file mode 100644 (file)
index 0000000..f97a013
--- /dev/null
@@ -0,0 +1,80 @@
+--- configure.old      2007-01-12 19:32:55.000000000 +0100
++++ configure  2007-01-13 19:27:26.000000000 +0100
+@@ -2007,31 +2007,8 @@
+    { (exit 1); exit 1; }; }
+ fi
+-{ echo "$as_me:$LINENO: checking if ${EMACS} is XEmacs" >&5
+-echo $ECHO_N "checking if ${EMACS} is XEmacs... $ECHO_C" >&6; }
+-
+-  elisp="(if (featurep (quote xemacs)) \"yes\" \"no\")"
+-  OUTPUT=./conftest-$$
+-  echo "${EMACS}" -batch -no-site-file -eval "(let* ((x ${elisp})) (write-region (if (stringp x) x (prin1-to-string x)) nil \"${OUTPUT}\"))"  >& 5 2>&1
+-  "${EMACS}" -batch -no-site-file -eval "(let* ((x ${elisp})) (write-region (if (stringp x) x (prin1-to-string x)) nil \"${OUTPUT}\"))"  >& 5 2>&1
+-  XEMACS="`cat ${OUTPUT}`"
+-  echo "=> ${XEMACS}" >& 5 2>&1
+-  rm -f ${OUTPUT}
+-
+-if test "${XEMACS}" = "yes"; then
+-  EMACS_FLAVOR=xemacs
+-  EMACS_NAME="XEmacs"
+-elif test "${XEMACS}" = "no"; then
+-  EMACS_FLAVOR=emacs
+-  EMACS_NAME="Emacs"
+-else
+-  { { echo "$as_me:$LINENO: error: Unable to run ${EMACS}!  Aborting!" >&5
+-echo "$as_me: error: Unable to run ${EMACS}!  Aborting!" >&2;}
+-   { (exit 1); exit 1; }; }
+-fi
+-  { echo "$as_me:$LINENO: result: ${XEMACS}" >&5
+-echo "${ECHO_T}${XEMACS}" >&6; }
+-
++EMACS_FLAVOR=emacs
++EMACS_NAME="Emacs"
+   { echo "$as_me:$LINENO: checking for ${EMACS_NAME} prefix" >&5
+ echo $ECHO_N "checking for ${EMACS_NAME} prefix... $ECHO_C" >&6; }
+@@ -2056,34 +2033,6 @@
+ echo "${ECHO_T}\"${emacsprefix}\"" >&6; }
+-if test ${EMACS_FLAVOR} = xemacs
+-then
+-
+-{ echo "$as_me:$LINENO: checking if ${EMACS_NAME} is recent enough" >&5
+-echo $ECHO_N "checking if ${EMACS_NAME} is recent enough... $ECHO_C" >&6; }
+-
+-  elisp="(cond ((< emacs-major-version 21) \"no\")
+-                       ((> emacs-major-version 21) \"yes\")
+-                       ((< emacs-minor-version 04) \"no\")
+-                       (t \"yes\"))"
+-  OUTPUT=./conftest-$$
+-  echo "${EMACS}" -batch -no-site-file -eval "(let* ((x ${elisp})) (write-region (if (stringp x) x (prin1-to-string x)) nil \"${OUTPUT}\"))"  >& 5 2>&1
+-  "${EMACS}" -batch -no-site-file -eval "(let* ((x ${elisp})) (write-region (if (stringp x) x (prin1-to-string x)) nil \"${OUTPUT}\"))"  >& 5 2>&1
+-  result="`cat ${OUTPUT}`"
+-  echo "=> ${result}" >& 5 2>&1
+-  rm -f ${OUTPUT}
+-
+-{ echo "$as_me:$LINENO: result: ${result}" >&5
+-echo "${ECHO_T}${result}" >&6; }
+-if test "${result}" != "yes"
+-then
+-  { { echo "$as_me:$LINENO: error: This package requires at least ${EMACS_NAME} version 21.4  Aborting!" >&5
+-echo "$as_me: error: This package requires at least ${EMACS_NAME} version 21.4  Aborting!" >&2;}
+-   { (exit 1); exit 1; }; }
+-fi
+-
+-else
+-
+ { echo "$as_me:$LINENO: checking if ${EMACS_NAME} is recent enough" >&5
+ echo $ECHO_N "checking if ${EMACS_NAME} is recent enough... $ECHO_C" >&6; }
+@@ -2107,8 +2056,6 @@
+    { (exit 1); exit 1; }; }
+ fi
+-fi
+-
+ { echo "$as_me:$LINENO: checking for MULE support" >&5
+ echo $ECHO_N "checking for MULE support... $ECHO_C" >&6; }
diff --git a/app-emacs/auctex/files/digest-auctex-11.84 b/app-emacs/auctex/files/digest-auctex-11.84
new file mode 100644 (file)
index 0000000..c88a621
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 73970c51221524442c11cde13d0584e9 auctex-11.84.tar.gz 927517
+RMD160 305f5327eac1bfe7f2770deb6617a50926c65f4f auctex-11.84.tar.gz 927517
+SHA256 3f25e99ddecc21422bbddf27ecbfcab49b187eb00f69788aaba1cf818fe557d1 auctex-11.84.tar.gz 927517