dev-ruby/test_construct: Add ruby23, remove ~ppc, ~x86
authorManuel Rüger <mrueg@gentoo.org>
Sat, 29 Oct 2016 15:03:09 +0000 (17:03 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Sat, 29 Oct 2016 15:03:09 +0000 (17:03 +0200)
Package-Manager: portage-2.3.2

dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild b/dev-ruby/test_construct/test_construct-2.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..fcddd25
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Creates temporary files and directories for testing"
+HOMEPAGE="https://github.com/bhb/test_construct"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+       >=dev-ruby/minitest-5.0.8
+       >=dev-ruby/mocha-0.14.0
+       dev-ruby/rspec:3
+)"
+
+all_ruby_prepare() {
+       sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}