dev-ml/camlzip: remove old
authorAlexis Ballier <aballier@gentoo.org>
Thu, 26 Jan 2017 11:42:17 +0000 (12:42 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 26 Jan 2017 11:42:17 +0000 (12:42 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/camlzip/Manifest
dev-ml/camlzip/camlzip-1.05.ebuild [deleted file]
dev-ml/camlzip/files/ocaml-4.03.patch [deleted file]

index 2ba048a372dfa613f23486b8ed90baf75f96de92..83111738a87f4944f4ae3afb2ef8734edd09551f 100644 (file)
@@ -1,2 +1 @@
-DIST camlzip-1.05.tar.gz 25817 SHA256 930b70c736ab5a7ed1b05220102310a0a2241564786657abe418e834a538d06b SHA512 5128243fc7528e5ec6cbb7d9b121e8cb0b6d486a95a82161cd74cafe05454602c9952ed6fee3d38a53614e5ecdc20ef88437681107c5952bf85b8f8c78bf042d WHIRLPOOL 26d2bf8d08a425b2297a913ec140fdfff78a31eb9a09e3641b38face44994c2f322354fddd9b96c003df74479e3d40dd12b5d9243160eeadd466b66e896b1acd
 DIST camlzip-1.06.tar.gz 26499 SHA256 c83877f9972943e6f2e147cf9715a785da2fc8531e7bed3ab4787043b8f4cf54 SHA512 5ef0172927106589620678897f12f054533503a5cf13df71bf4deda43f223d0cd6acce118977e87bce53afe289f367b851f192a8e693274c2bd13549121019dd WHIRLPOOL a83ad24836d64adc00324f44ce5f3877c8d912afe14dcb0ad5b8788a52dfe777b2b582e240e74ed24bda950ca0202505792e62f9c205f0a5f39c33918e70217a
diff --git a/dev-ml/camlzip/camlzip-1.05.ebuild b/dev-ml/camlzip/camlzip-1.05.ebuild
deleted file mode 100644 (file)
index f95082e..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit findlib eutils
-
-IUSE="+ocamlopt"
-
-DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
-HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
-SRC_URI="http://forge.ocamlcore.org/frs/download.php/1037/${P}.tar.gz"
-
-SLOT="1/${PV}"
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-
-RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
-               >=sys-libs/zlib-1.1.3"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
-       has_version '>=dev-lang/ocaml-4.03.0_beta1' && epatch "${FILESDIR}/ocaml-4.03.patch"
-}
-
-src_compile() {
-       emake all
-       if use ocamlopt; then
-               emake allopt
-       fi
-}
-
-src_install() {
-       findlib_src_preinst
-       emake DESTDIR="${D}" install-findlib
-
-       dodoc README Changes
-}
diff --git a/dev-ml/camlzip/files/ocaml-4.03.patch b/dev-ml/camlzip/files/ocaml-4.03.patch
deleted file mode 100644 (file)
index 4982242..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: camlzip-1.05/zip.ml
-===================================================================
---- camlzip-1.05.orig/zip.ml
-+++ camlzip-1.05/zip.ml
-@@ -73,8 +73,6 @@ type out_file =
-     mutable of_entries: entry list;
-     of_comment: string }
--exception Error of string * string * string
--
- (* Return the position of the last occurrence of s1 in s2, or -1 if not
-    found. *)
-Index: camlzip-1.05/zlibstubs.c
-===================================================================
---- camlzip-1.05.orig/zlibstubs.c
-+++ camlzip-1.05/zlibstubs.c
-@@ -168,7 +168,7 @@ value camlzip_inflateEnd(value vzs)
- value camlzip_update_crc32(value crc, value buf, value pos, value len)
- {
--  return caml_copy_int32(crc32((uint32) Int32_val(crc), 
-+  return caml_copy_int32(crc32((uint32_t) Int32_val(crc), 
-                           &Byte_u(buf, Long_val(pos)),
-                           Long_val(len)));
- }