sys-fs/zfs-kmod: drop 0.8.2
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 30 Mar 2020 19:10:03 +0000 (12:10 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 30 Mar 2020 21:07:44 +0000 (14:07 -0700)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
sys-fs/zfs-kmod/Manifest
sys-fs/zfs-kmod/files/0.8.2-umask_O_TMPFILE.patch [deleted file]
sys-fs/zfs-kmod/zfs-kmod-0.8.2-r2.ebuild [deleted file]

index 84cfb1d2a3e7a8998f5a7bafb4cb4a715e1f3766..5de6d1f5c7741dfe7844dc25703d130a379aadf4 100644 (file)
@@ -1,3 +1,2 @@
 DIST zfs-0.7.13.tar.gz 6614047 BLAKE2B c59c46287715779eb04d69333b0a417fa9865eb0d61c642b043188c4c97d4eed369f76a48327326ed1d4dd608ff95d91d20d26c80ed0b120a8fcd5f83cea638f SHA512 457d8f110b68c9656194cd3738b216d5d807d680e5cfc6ed1f3cf5ebde67860476387c6b862ba3ba7f972d8945075963e6c325543ab84468e3eff5dbce68476e
-DIST zfs-0.8.2.tar.gz 8738111 BLAKE2B 5c15f6664ca70f0deeb5b9e32f2bcff68f9821529e5203ff18612ce88473fee9af369354c442f3db7882d301cf17c805c9635b05bfd3460833ed8e5ff8004dd0 SHA512 1424b1a030b814f812b5da422100669db5b8c3ccae14c2fdd62a5e0df28e7255247fe5ca99c95a14f08c92cc1574c22dd132093e4a1dd81e38c95b10cc5e2496
 DIST zfs-0.8.3.tar.gz 8779385 BLAKE2B 8b51b9d5b61543566bc7839d8452fdf9358442155e95f93a011531338824bbd4fc8879500e276b02d5d49d504a046728ecc0c6154f69eb7b47180b9bb0e46958 SHA512 aded632e6b04180560d4f2ff283260016e883dadae4e7fda9070b7113dee948099cb7a7b183f1c8139654389a2610fb9cc6f997acdc846040e605125cf016010
diff --git a/sys-fs/zfs-kmod/files/0.8.2-umask_O_TMPFILE.patch b/sys-fs/zfs-kmod/files/0.8.2-umask_O_TMPFILE.patch
deleted file mode 100644 (file)
index 9252b6e..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From ddb4e69db5eb0ed741dc4e32714af3e0f054086c Mon Sep 17 00:00:00 2001
-From: Tomohiro Kusumi <kusumi.tomohiro@gmail.com>
-Date: Sat, 14 Dec 2019 08:02:23 +0900
-Subject: [PATCH] Don't fail to apply umask for O_TMPFILE files
-
-Apply umask to `mode` which will eventually be applied to inode.
-This is needed since VFS doesn't apply umask for O_TMPFILE files.
-
-(Note that zpl_init_acl() applies `ip->i_mode &= ~current_umask();`
-only when POSIX ACL is used.)
-
-Reviewed-by: Brian Behlendorf <behlendorf1@llnl.gov>
-Reviewed-by: Tony Hutter <hutter2@llnl.gov>
-Signed-off-by: Tomohiro Kusumi <kusumi.tomohiro@gmail.com>
-Closes #8997
-Closes #8998
-
-diff --git a/module/zfs/zpl_inode.c b/module/zfs/zpl_inode.c
-index 264c5d2b1cf..e1c6ce7b705 100644
---- a/module/zfs/zpl_inode.c
-+++ b/module/zfs/zpl_inode.c
-@@ -218,6 +218,12 @@ zpl_tmpfile(struct inode *dir, struct dentry *dentry, umode_t mode)
-       crhold(cr);
-       vap = kmem_zalloc(sizeof (vattr_t), KM_SLEEP);
-+      /*
-+       * The VFS does not apply the umask, therefore it is applied here
-+       * when POSIX ACLs are not enabled.
-+       */
-+      if (!IS_POSIXACL(dir))
-+              mode &= ~current_umask();
-       zpl_vap_init(vap, dir, mode, cr);
-       cookie = spl_fstrans_mark();
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.8.2-r2.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.8.2-r2.ebuild
deleted file mode 100644 (file)
index 961ee26..0000000
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic linux-info linux-mod toolchain-funcs
-
-DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
-HOMEPAGE="https://zfsonlinux.org/"
-
-if [[ ${PV} == "9999" ]]; then
-       inherit autotools git-r3
-       EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
-else
-       SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${PV}/zfs-${PV}.tar.gz"
-       KEYWORDS="~amd64 ~arm64 ~ppc64"
-       S="${WORKDIR}/zfs-${PV}"
-       ZFS_KERNEL_COMPAT="5.4"
-fi
-
-LICENSE="CDDL debug? ( GPL-2+ )"
-SLOT="0"
-IUSE="custom-cflags debug +rootfs"
-
-DEPEND=""
-
-RDEPEND="${DEPEND}
-       !sys-fs/zfs-fuse
-       !sys-kernel/spl
-"
-
-BDEPEND="
-       dev-lang/perl
-       virtual/awk
-"
-
-RESTRICT="debug? ( strip ) test"
-
-DOCS=( AUTHORS COPYRIGHT META README.md )
-
-PATCHES=( "${FILESDIR}/${PV}-umask_O_TMPFILE.patch" )
-
-pkg_setup() {
-       linux-info_pkg_setup
-
-       CONFIG_CHECK="
-               !DEBUG_LOCK_ALLOC
-               EFI_PARTITION
-               MODULES
-               !PAX_KERNEXEC_PLUGIN_METHOD_OR
-               !TRIM_UNUSED_KSYMS
-               ZLIB_DEFLATE
-               ZLIB_INFLATE
-       "
-
-       use debug && CONFIG_CHECK="${CONFIG_CHECK}
-               FRAME_POINTER
-               DEBUG_INFO
-               !DEBUG_INFO_REDUCED
-       "
-
-       use rootfs && \
-               CONFIG_CHECK="${CONFIG_CHECK}
-                       BLK_DEV_INITRD
-                       DEVTMPFS
-       "
-
-       if use arm64; then
-               kernel_is -ge 5 && CONFIG_CHECK="${CONFIG_CHECK} !PREEMPT"
-       fi
-
-       kernel_is -lt 5 && CONFIG_CHECK="${CONFIG_CHECK} IOSCHED_NOOP"
-
-       kernel_is -ge 2 6 32 || die "Linux 2.6.32 or newer required"
-
-       if [[ ${PV} != "9999" ]]; then
-               local kv_major_max kv_minor_max zcompat
-               zcompat="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
-               kv_major_max="${zcompat%%.*}"
-               zcompat="${zcompat#*.}"
-               kv_minor_max="${zcompat%%.*}"
-               kernel_is -le "${kv_major_max}" "${kv_minor_max}" || die \
-                       "Linux ${kv_major_max}.${kv_minor_max} is the latest supported version"
-       fi
-
-       check_extra_config
-}
-
-src_prepare() {
-       default
-
-       if [[ ${PV} == "9999" ]]; then
-               eautoreconf
-       else
-               # Set module revision number
-               sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
-       fi
-
-       # Remove GPLv2-licensed ZPIOS unless we are debugging
-       use debug || sed -e 's/^subdir-m += zpios$//' -i module/Makefile.in
-}
-
-src_configure() {
-       set_arch_to_kernel
-
-       use custom-cflags || strip-flags
-
-       filter-ldflags -Wl,*
-
-       local myconf=(
-               --bindir="${EPREFIX}/bin"
-               --sbindir="${EPREFIX}/sbin"
-               --with-config=kernel
-               --with-linux="${KV_DIR}"
-               --with-linux-obj="${KV_OUT_DIR}"
-               $(use_enable debug)
-       )
-
-       econf "${myconf[@]}"
-}
-
-src_compile() {
-       set_arch_to_kernel
-
-       myemakeargs=( V=1 )
-
-       emake "${myemakeargs[@]}"
-}
-
-src_install() {
-       set_arch_to_kernel
-
-       myemakeargs+=(
-               DEPMOD="/bin/true"
-               DESTDIR="${D}"
-               INSTALL_MOD_PATH="${INSTALL_MOD_PATH:-$EROOT}"
-       )
-
-       emake "${myemakeargs[@]}" install
-
-       einstalldocs
-}
-
-pkg_postinst() {
-       linux-mod_pkg_postinst
-
-       # Remove old modules
-       if [[ -d "${EROOT}/lib/modules/${KV_FULL}/addon/zfs" ]]; then
-               ewarn "${PN} now installs modules in ${EROOT}/lib/modules/${KV_FULL}/extra/zfs"
-               ewarn "Old modules were detected in ${EROOT}/lib/modules/${KV_FULL}/addon/zfs"
-               ewarn "Automatically removing old modules to avoid problems."
-               rm -r "${EROOT}/lib/modules/${KV_FULL}/addon/zfs" || die "Cannot remove modules"
-               rmdir --ignore-fail-on-non-empty "${EROOT}/lib/modules/${KV_FULL}/addon"
-       fi
-
-       if use x86 || use arm; then
-               ewarn "32-bit kernels will likely require increasing vmalloc to"
-               ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
-       fi
-
-       ewarn "This version of ZFSOnLinux includes support for new feature flags"
-       ewarn "that are incompatible with previous versions. GRUB2 support for"
-       ewarn "/boot with the new feature flags is not yet available."
-       ewarn "Do *NOT* upgrade root pools to use the new feature flags."
-       ewarn "Any new pools will be created with the new feature flags by default"
-       ewarn "and will not be compatible with older versions of ZFSOnLinux. To"
-       ewarn "create a newpool that is backward compatible wih GRUB2, use "
-       ewarn
-       ewarn "zpool create -d -o feature@async_destroy=enabled "
-       ewarn " -o feature@empty_bpobj=enabled -o feature@lz4_compress=enabled"
-       ewarn " -o feature@spacemap_histogram=enabled"
-       ewarn " -o feature@enabled_txg=enabled "
-       ewarn " -o feature@extensible_dataset=enabled -o feature@bookmarks=enabled"
-       ewarn " ..."
-       ewarn
-       ewarn "GRUB2 support will be updated as soon as either the GRUB2"
-       ewarn "developers do a tag or the Gentoo developers find time to backport"
-       ewarn "support from GRUB2 HEAD."
-}