dev-python/setuptools: version bump to 38.5.1
authorTim Harder <radhermit@gentoo.org>
Fri, 9 Feb 2018 07:19:38 +0000 (02:19 -0500)
committerTim Harder <radhermit@gentoo.org>
Fri, 9 Feb 2018 07:19:38 +0000 (02:19 -0500)
dev-python/setuptools/Manifest
dev-python/setuptools/setuptools-38.5.1.ebuild [new file with mode: 0644]

index 9c2325ba4a5c59822530c3d0a7a7e614d7ad0c7e..2e0905b8328197191c02e513ed1980ca496aefab 100644 (file)
@@ -1,3 +1,4 @@
 DIST setuptools-34.0.2.zip 617839 BLAKE2B c06ef384a42430ec8f4d956723d21f70fdcf993e41fb6d6e8b4fd18a7f12eeb957f9aef3e8b81e59f006452bd7dc8f59d6c5dec07ca099156f93fa74b5f4d152 SHA512 8ff6475620fc18e5992900dffd50158bfea980d3e7f2c7c98e8c99180b2f11b3f81c13a60f93516da580def2543a786940cc164dcdc36802d9657c48e45d9266
 DIST setuptools-36.0.1.zip 711296 BLAKE2B c58a4efd8d3a2d574ff6ba5cd01a196fc7ad61a238119ac95714239965875d91e4613d08439c63ab3b9a0794b04ead5c6e8de09839e0306e4d29f47c2c7a7c58 SHA512 cbcd2591d0d8a7591c5d9a1d4173814afa0b984af29f2e34d26a37c357474b043f371978ac224cea12f50834d91babd9f14b137488c4edcd62594e91aff903d8
 DIST setuptools-36.7.2.zip 726758 BLAKE2B 8821d3142f2149fbdea4d231052c3990fa7a14c57c421309683c6a65102ce4911850acd5d492087aa0f14a0026da732e47eb9bf971030443fc1b57f9f909aaaa SHA512 746dce135dbacb65565787a20a2611388605e2371c94f0f8803e7712e515e69c270751d16a21f381bf6e8ddc0a1b39494db7d0c67bb32e6230a90c5d517e78f9
+DIST setuptools-38.5.1.zip 737995 BLAKE2B 9772d39928c6633ca529292d646c1c8e96a5a77ed06545af950cc249922837c13722d97de702c1e104581d56e1f808ec3d077041212517f5a51b23aa2e95e734 SHA512 bd04186a6e73cf24440e82aee10fff09889cab53e2e2fbf178bdb1360accf4f787abf8d8421d5e0fcb41005254c091f62d714e8b317ecf68911e2eed87b9fcc4
diff --git a/dev-python/setuptools/setuptools-38.5.1.ebuild b/dev-python/setuptools/setuptools-38.5.1.ebuild
new file mode 100644 (file)
index 0000000..ef15964
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+       EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+       KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.python.org/pypi/setuptools"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}
+       app-arch/unzip
+       test? (
+               dev-python/pip[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]
+               dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+               dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+               >=dev-python/backports-unittest-mock-1.2[${PYTHON_USEDEP}]
+               dev-python/wheel[${PYTHON_USEDEP}]
+       )
+"
+PDEPEND="
+       >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+       if [[ ${PV} == "9999" ]]; then
+               python_setup
+               ${EPYTHON} bootstrap.py || die
+       fi
+
+       # disable tests requiring a network connection
+       rm setuptools/tests/test_packageindex.py || die
+
+       # don't run integration tests
+       rm setuptools/tests/test_integration.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+       # It tries to sandbox the test in a tempdir
+       HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+       export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+       distutils-r1_python_install
+}