dev-lua/luarocks: version bump to 3.3.1
authorVictor Payno <vpayno+gentoo@gmail.com>
Mon, 2 Mar 2020 22:21:40 +0000 (14:21 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 15 Mar 2020 22:07:27 +0000 (15:07 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14406
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lua/luarocks/Manifest
dev-lua/luarocks/luarocks-3.3.1.ebuild [new file with mode: 0644]
dev-lua/luarocks/metadata.xml

index 0d8375a6e0ddaf822427f2c4930178efed61cb0b..fbace4ca97bd5a45f9d1a5bbc7833578a497af33 100644 (file)
@@ -1,2 +1,3 @@
 DIST luarocks-2.2.0.tar.gz 111549 BLAKE2B 214c1c03e03f95ca1acfc1fda863895c91c508221c615fe3ccc064e9adbcaa8549d24ff788141c0093259ca52578fadccfb3f6891209f86336c57937ac5ec32d SHA512 41f32e383263485758e64df661ecfbd744369035362755c64466f2c52a8740ed941b80cab3212222d7d24e4b1a7ed9ccb84fa66c8e458526056af0b06d97224f
 DIST luarocks-3.2.1.tar.gz 232149 BLAKE2B f8298ef054f50b8f70bf48748435a54f683ba8eef3113641e98b00e1aa872b95e75b36f0df96de7870d3576d3b9149dde8af1b68a3d7ceda86d3654dbad507c0 SHA512 9abf2c5477b9ab8e3caf485dd10fc154435b41efc13c7709f36a9182ccbd98d022738627f76901977a9b7c42ae61e5f139e78070d469094a7571910afbb747ff
+DIST luarocks-3.3.1.tar.gz 241636 BLAKE2B fd34d7a233bbf1c5f224bd04886a7f1382d63ffc014c8b78ae7924fb799d66a32e048298deed103686771263885c85c9173c013d1bbb3bad6a48e9fd99fdaac0 SHA512 0a695ceb30ae575cbca52abd2aad9675e33a234c53c5d1e125442d874c21e0e3cf6157431f07085e4311f81833680366adfe5c626a66cb5880380b48899a116a
diff --git a/dev-lua/luarocks/luarocks-3.3.1.ebuild b/dev-lua/luarocks/luarocks-3.3.1.ebuild
new file mode 100644 (file)
index 0000000..9cade0b
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua:=
+       dev-libs/openssl:=
+       net-misc/curl"
+BDEPEND="${RDEPEND}
+       virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       # econf doesn't work b/c it passes variables the custom configure can't
+       # handle
+       ./configure \
+                       --prefix="${EPRIFIX}/usr" \
+                       --with-lua-lib="${EPRIFIX}/usr/$(get_libdir)" \
+                       --rocks-tree="${EPRIFIX}/usr/$(get_libdir)/lua/luarocks" \
+                       || die "configure failed"
+}
+
+src_install() {
+       default
+       { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die "sed failed"
+}
index 4b6ecc153af0524aec6194c051818642ff5ffc59..da075190f828c4d42744ca92873461c60ad7d0ff 100644 (file)
@@ -5,6 +5,10 @@
                <email>vpayno+gentoo@gmail.com</email>
                <name>Victor Payno</name>
        </maintainer>
+       <maintainer type="person">
+               <email>gyakovlev@gentoo.org</email>
+               <name>Georgy Yakovlev</name>
+       </maintainer>
        <use>
                <flag name="curl">Uses <pkg>net-misc/curl</pkg> for fetching lua
                        packages instead of <pkg>net-misc/wget</pkg>.</flag>
@@ -13,6 +17,8 @@
        </use>
        <longdescription lang="en">
                Package manager for Lua.
+
+               It allows you to create and install Lua modules as self-contained packages called rocks.
        </longdescription>
        <upstream>
                <remote-id type="github">luarocks/luarocks</remote-id>