media-libs/libcdr: Fix build with boost-1.59 (bug 574120)
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Sat, 6 Feb 2016 21:51:53 +0000 (22:51 +0100)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 22 Feb 2016 17:05:58 +0000 (18:05 +0100)
KEYWORDS: Dropped ppc (missing in librevenge)
Also drop base.eclass

Package-Manager: portage-2.2.27

media-libs/libcdr/files/libcdr-0.1.1-boost-1.59.patch [new file with mode: 0644]
media-libs/libcdr/libcdr-0.1.0.ebuild
media-libs/libcdr/libcdr-0.1.1.ebuild
media-libs/libcdr/libcdr-0.1.2-r1.ebuild [moved from media-libs/libcdr/libcdr-0.1.2.ebuild with 91% similarity]
media-libs/libcdr/libcdr-9999.ebuild

diff --git a/media-libs/libcdr/files/libcdr-0.1.1-boost-1.59.patch b/media-libs/libcdr/files/libcdr-0.1.1-boost-1.59.patch
new file mode 100644 (file)
index 0000000..e32f3fe
--- /dev/null
@@ -0,0 +1,32 @@
+From 882a4b3f83a4b5097da53670c720a26f4e2750eb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fridrich=20=C5=A0trba?= <fridrich.strba@bluewin.ch>
+Date: Sun, 13 Dec 2015 20:37:16 +0100
+Subject: [PATCH] Some boost 1.59 fixes
+
+Change-Id: I0054c977a6d8ff5a9b93c147578e890476365999
+---
+ src/lib/Makefile.am | 11 +++++++++--
+ 1 file changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
+index 3f00cc5..e14fa8c 100644
+--- a/src/lib/Makefile.am
++++ b/src/lib/Makefile.am
+@@ -13,8 +13,16 @@ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_include_HEADERS = \
+       $(top_srcdir)/inc/libcdr/CDRDocument.h \
+       $(top_srcdir)/inc/libcdr/CMXDocument.h
+-AM_CXXFLAGS = -I$(top_srcdir)/inc $(REVENGE_CFLAGS) $(LCMS2_CFLAGS) $(ZLIB_CFLAGS) $(ICU_CFLAGS) $(DEBUG_CXXFLAGS) -DLIBCDR_BUILD=1
++AM_CXXFLAGS = -I$(top_srcdir)/inc \
++      $(REVENGE_CFLAGS) \
++      $(LCMS2_CFLAGS) \
++      $(ZLIB_CFLAGS) \
++      $(ICU_CFLAGS) \
++      $(DEBUG_CXXFLAGS) \
++      -DLIBCDR_BUILD=1 \
++      -DBOOST_ERROR_CODE_HEADER_ONLY \
++      -DBOOST_SYSTEM_NO_DEPRECATED
+ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_LIBADD  = $(REVENGE_LIBS) $(LCMS2_LIBS) $(ZLIB_LIBS) $(ICU_LIBS) @LIBCDR_WIN32_RESOURCE@
+ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_DEPENDENCIES = @LIBCDR_WIN32_RESOURCE@
+ libcdr_@CDR_MAJOR_VERSION@_@CDR_MINOR_VERSION@_la_LDFLAGS = $(version_info) -export-dynamic -no-undefined
index 3484f9b3c89e06d1c5d380c2966da25ac1ee86cf..da99f3dc091e934c04df7b57c4c1355a0020ef43 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 
 EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
+inherit autotools eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
 
 DESCRIPTION="Library parsing the Corel cdr documents"
 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
@@ -32,9 +32,10 @@ DEPEND="${RDEPEND}
 "
 
 src_prepare() {
-       base_src_prepare
+       epatch "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
+       epatch_user
        [[ -d m4 ]] || mkdir "m4"
-       [[ ${PV} == 9999 ]] && eautoreconf
+       eautoreconf
 }
 
 src_configure() {
index 158c828fc6cdf75eec0cef49e57d496284262061..c7dba09ebc06413b1353304ab2426cca1319e771 100644 (file)
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=5
 
 EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
+inherit autotools eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
 
 DESCRIPTION="Library parsing the Corel cdr documents"
 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
@@ -32,9 +32,10 @@ DEPEND="${RDEPEND}
 "
 
 src_prepare() {
-       base_src_prepare
+       epatch "${FILESDIR}/${PN}-0.1.1-boost-1.59.patch"
+       epatch_user
        [[ -d m4 ]] || mkdir "m4"
-       [[ ${PV} == 9999 ]] && eautoreconf
+       eautoreconf
 }
 
 src_configure() {
similarity index 91%
rename from media-libs/libcdr/libcdr-0.1.2.ebuild
rename to media-libs/libcdr/libcdr-0.1.2-r1.ebuild
index b0fd8db6ef5a3a643e7099fa5038aa0026a3124b..d818832699f5adeda580f6bad1a07ddd57b277f3 100644 (file)
@@ -2,11 +2,11 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
 EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
 
 DESCRIPTION="Library parsing the Corel cdr documents"
 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
 "
 
 src_prepare() {
-       base_src_prepare
+       eapply_user
        [[ -d m4 ]] || mkdir "m4"
        [[ ${PV} == 9999 ]] && eautoreconf
 }
index b0fd8db6ef5a3a643e7099fa5038aa0026a3124b..d818832699f5adeda580f6bad1a07ddd57b277f3 100644 (file)
@@ -2,11 +2,11 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
 
 EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libcdr/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-2
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
 
 DESCRIPTION="Library parsing the Corel cdr documents"
 HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
@@ -33,7 +33,7 @@ DEPEND="${RDEPEND}
 "
 
 src_prepare() {
-       base_src_prepare
+       eapply_user
        [[ -d m4 ]] || mkdir "m4"
        [[ ${PV} == 9999 ]] && eautoreconf
 }