dev-java/cpptasks: Delete old.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 23 Aug 2015 18:33:25 +0000 (18:33 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 23 Aug 2015 19:24:23 +0000 (19:24 +0000)
Package-Manager: portage-2.2.18
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
dev-java/cpptasks/Manifest
dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild [deleted file]

index 578f75c8e6416f15b2d8aea75f15f61ad31823eb..04aea91274ffe5bdcdd4162179c3e0ec600d4b4c 100644 (file)
@@ -1,2 +1 @@
-DIST cpptasks-1.0b4.tar.gz 879715 SHA256 3472af7389c5a7daaff48a054c2b9f10994b55352025b8a2249a7dfcebca14c8 SHA512 6e12ac6f4a96d36b50e3f0d105038feef16e70f0980959671245bc88dbd170a9dd42b39b884a0b2f6e7d055b9588462d0a290587919605e8503979cc575aede5 WHIRLPOOL c4f264e275201aacf732a73fb52f2aad02b26581ca4572d30ab4ab768ff29a66f5c01f617efa38a49ac93b779d63711aa479e2143c6b01b443c4fe1c973fd3bd
 DIST cpptasks-1.0b5.tar.gz 902930 SHA256 d181cee0c4e28bed202f8bf582dc42bbc824c7712ea29c7b17f036fc7cdfc209 SHA512 620d16e60cdd4d8a09efe6c5889ec1beb20d38df3a7ebf337de546cd60881b4c22a08f24374e7dac02dbbb3b23defbb740a70f1d0ff59212496e631251f0e32c WHIRLPOOL 1eb3a0726d43a40453a7a70c89b2fdf8880979a52f8dac6cab9a01800184c72d084d603a647804dd6a55a162a20fd2102818fb415336e21beeb010bd3b7eb196
diff --git a/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild b/dev-java/cpptasks/cpptasks-1.0_beta4-r2.ebuild
deleted file mode 100644 (file)
index ee4d19e..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit java-pkg-2 java-ant-2
-
-MY_P="${PN}-${PV/_beta/b}"
-DESCRIPTION="Ant tasks to compile various source languages and produce executables, shared and static libraries"
-HOMEPAGE="http://ant-contrib.sourceforge.net/"
-SRC_URI="mirror://sourceforge/ant-contrib/${MY_P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="doc source examples"
-
-RDEPEND=">=virtual/jre-1.4
-        >=dev-java/ant-core-1.7
-        >=dev-java/xerces-2.7"
-DEPEND=">=virtual/jdk-1.4
-       ${RDEPEND}
-       source? ( app-arch/zip )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
-       unpack ${A}
-       # https://sourceforge.net/tracker/index.php?func=detail&aid=829906&group_id=36177&atid=416920
-       # https://bugs.gentoo.org/show_bug.cgi?id=156596
-       epatch "${FILESDIR}/1.0b4-profiling.patch"
-
-       cd "${S}"
-       # in svn but missing from the release
-       cp "${FILESDIR}/antlib.xml" src/net/sf/antcontrib/cpptasks/antlib.xml || die
-       rm -v *.jar || die
-       java-ant_rewrite-classpath
-}
-
-EANT_BUILD_TARGET="jars"
-EANT_DOC_TARGET="javadocs -Dbuild.javadocs=build/api"
-EANT_GENTOO_CLASSPATH="ant-core,xerces-2"
-
-#The actual files for testing are not part of the release
-#src_test() {
-#      eant run-tests
-#}
-
-src_install() {
-       java-pkg_dojar build/lib/${PN}.jar
-
-       java-pkg_register-ant-task
-
-       dodoc NOTICE || die
-       use doc && java-pkg_dojavadoc build/api
-       use examples && dodoc samples/*
-       use source && java-pkg_dosrc src/net
-
-}