app-emulation/libvirt: Check for more kernel configs for virtual net
authorMichal Privoznik <mprivozn@redhat.com>
Mon, 8 Apr 2019 01:08:54 +0000 (20:08 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Mon, 8 Apr 2019 02:29:38 +0000 (21:29 -0500)
After 7431b3eb9a05068e4b Libvirt starts to create chains to
insert rules into instead of placing them right at the top level
chains. These private chains are created on daemon startup and
the referenced commit made all 6 tables required (combination of
default 3 tables: nat, filter and mangle for both IPv4 and IPv6).
This was later refined in 686803a1a2e1e06, but it still makes
sense for ebuild to check for all tables being enabled in the
kernel because both IPv4 and IPv6 are used widely.

Package-Manager: Portage-2.3.62, Repoman-2.3.12
Closes: https://bugs.gentoo.org/681010
Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/libvirt/libvirt-5.0.0-r1.ebuild
app-emulation/libvirt/libvirt-5.1.0.ebuild
app-emulation/libvirt/libvirt-9999.ebuild

index dd115c7a957b321547330ca9be31e92c80501218..be886fc4954444c7d033c7168509be81d4a164b5 100644 (file)
@@ -187,7 +187,14 @@ pkg_setup() {
                ~NETFILTER_ADVANCED
                ~NETFILTER_XT_CONNMARK
                ~NETFILTER_XT_MARK
-               ~NETFILTER_XT_TARGET_CHECKSUM"
+               ~NETFILTER_XT_TARGET_CHECKSUM
+               ~IP_NF_FILTER
+               ~IP_NF_MANGLE
+               ~IP_NF_NAT
+               ~IP_NF_TARGET_MASQUERADE
+               ~IP6_NF_FILTER
+               ~IP6_NF_MANGLE
+               ~IP6_NF_NAT"
        # Bandwidth Limiting Support
        use virt-network && CONFIG_CHECK+="
                ~BRIDGE_EBT_T_NAT
index d0b9652fb37a57b4e186bc8f8cf5f1ee84728a61..f1b5ef7bfb683216e649abae639a28c86094fd7c 100644 (file)
@@ -187,7 +187,14 @@ pkg_setup() {
                ~NETFILTER_ADVANCED
                ~NETFILTER_XT_CONNMARK
                ~NETFILTER_XT_MARK
-               ~NETFILTER_XT_TARGET_CHECKSUM"
+               ~NETFILTER_XT_TARGET_CHECKSUM
+               ~IP_NF_FILTER
+               ~IP_NF_MANGLE
+               ~IP_NF_NAT
+               ~IP_NF_TARGET_MASQUERADE
+               ~IP6_NF_FILTER
+               ~IP6_NF_MANGLE
+               ~IP6_NF_NAT"
        # Bandwidth Limiting Support
        use virt-network && CONFIG_CHECK+="
                ~BRIDGE_EBT_T_NAT
index 39626cb3fae93b3f5d13d95c640623d6ab22cd32..71ce26a41fbccd50918c3c26ef4a3c91f1204705 100644 (file)
@@ -187,7 +187,14 @@ pkg_setup() {
                ~NETFILTER_ADVANCED
                ~NETFILTER_XT_CONNMARK
                ~NETFILTER_XT_MARK
-               ~NETFILTER_XT_TARGET_CHECKSUM"
+               ~NETFILTER_XT_TARGET_CHECKSUM
+               ~IP_NF_FILTER
+               ~IP_NF_MANGLE
+               ~IP_NF_NAT
+               ~IP_NF_TARGET_MASQUERADE
+               ~IP6_NF_FILTER
+               ~IP6_NF_MANGLE
+               ~IP6_NF_NAT"
        # Bandwidth Limiting Support
        use virt-network && CONFIG_CHECK+="
                ~BRIDGE_EBT_T_NAT