app-admin/syslog-ng: bump to 3.16.1
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 22 Jun 2018 13:28:45 +0000 (15:28 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 22 Jun 2018 13:28:45 +0000 (15:28 +0200)
Closes: https://github.com/gentoo/gentoo/pull/8907
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-admin/syslog-ng/Manifest
app-admin/syslog-ng/syslog-ng-3.16.1.ebuild [new file with mode: 0644]

index 2d6b68e6da4abcd97e95a00b3983f4e64adc461a..b31bf2d1badb00309035a01da6675cc84cbfd5a5 100644 (file)
@@ -1,4 +1,5 @@
 DIST syslog-ng-3.13.2.tar.gz 9047998 BLAKE2B a18b11a31e1bf4c981071e7509ff154f08076c5ca659e814a3d8a49108dcc6f324ba3025f4e43bb32d23a9554fc188da4b116089fe29bf866f323f76280c460f SHA512 fd5c6645f1e8e10cba940ea29715f9e7cc286cd49c2f45bde2a447731189d6171ca204aa066ac96dd09246fd7ed1751130d143d807c979518d688e7750490cfe
 DIST syslog-ng-3.14.1.tar.gz 9039910 BLAKE2B 688eb52557c41a2556835978809b74ef4cc6b78e54580c4f349a8b9ebc07a6cf5ab99d8cda2a0212cb0186fe9e0a276d46ab9846c5ed1c391d734596ccc2d0a9 SHA512 86e5b59f76de3f585781accc9e426b2f74a73a560a6b49364e3f2b71b6fdd382b8473b468ac396e09c1dd0e00aa525a25874af67ce6c81978df2995c9b920aa7
 DIST syslog-ng-3.15.1.tar.gz 9147238 BLAKE2B 86c51a51569efed2c2127a6102a10224a0599d40af0d34f28b5b52e314687851753f979a8d9edabdba02d347407b1b2856bce11991eeda53cbe10ad135934534 SHA512 79b4f2eff92bcbfe8a875bc72eb98bb43d86ef3c63deaf4acefcdad4f3a98df9de4e7935fc2ebbe017fd5eb22aa0743f1ff428d0ccf3790a1767f4e25c6a7b13
+DIST syslog-ng-3.16.1.tar.gz 8899693 BLAKE2B 850d83ff6f7e2db4aaf0737cc97403084bfa97855df28ccc8134c7d744cc0539e5d9efcd72f7eaa5407504897bc274419963843afa4c81964732dc5d6f0337cd SHA512 6b47e570ac19154f6158d8de0898c0a49e87d4ed51cae67224501e9460063efc53c4b2ad518d7def811d320f88cbefbf5d645de31f300498921652d7be305999
 DIST syslog-ng-3.7.3.tar.gz 3511155 BLAKE2B 25ba2ca241a5847c75792c78d39a4667f55cf1fcff46be5102256ee6a9d2f39e2042ac00fa0b1559f94e0df80a0853249692b443b565dd4f46f0354c453cacaf SHA512 e58d793bd1a8b48c5836090ee244f6e8b223f234f5a27fbf81f6a838b9b1e3e45f73a66dab2bc58a0bba230bd778a247ae22bf529a28fb2e9fee52b8181d304b
diff --git a/app-admin/syslog-ng/syslog-ng-3.16.1.ebuild b/app-admin/syslog-ng/syslog-ng-3.16.1.ebuild
new file mode 100644 (file)
index 0000000..27ecc33
--- /dev/null
@@ -0,0 +1,169 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit autotools eapi7-ver python-single-r1 systemd
+
+MY_PV_MM=$(ver_cut 1-2)
+DESCRIPTION="syslog replacement with advanced filtering features"
+HOMEPAGE="https://syslog-ng.com/open-source-log-management"
+SRC_URI="https://github.com/balabit/syslog-ng/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="amqp caps dbi geoip http ipv6 json libressl mongodb pacct python redis smtp spoof-source systemd tcpd"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+# unit tests require https://github.com/Snaipe/Criterion with additional deps
+RESTRICT="test"
+
+RDEPEND="
+       >=dev-libs/glib-2.10.1:2
+       >=dev-libs/ivykis-0.42.3
+       >=dev-libs/libpcre-6.1:=
+       !dev-libs/eventlog
+       amqp? ( >=net-libs/rabbitmq-c-0.8.0:= )
+       caps? ( sys-libs/libcap )
+       dbi? ( >=dev-db/libdbi-0.9.0 )
+       geoip? ( >=dev-libs/geoip-1.5.0 )
+       http? ( net-misc/curl )
+       json? ( >=dev-libs/json-c-0.9:= )
+       mongodb? ( >=dev-libs/mongo-c-driver-1.2.0 )
+       python? ( ${PYTHON_DEPS} )
+       redis? ( >=dev-libs/hiredis-0.11.0:= )
+       smtp? ( net-libs/libesmtp )
+       spoof-source? ( net-libs/libnet:1.1= )
+       systemd? ( sys-apps/systemd:= )
+       tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+       sys-devel/flex
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS.md CONTRIBUTING.md contrib/syslog-ng.conf.{HP-UX,RedHat,SunOS,doc}
+       contrib/syslog2ng "${T}/syslog-ng.conf.gentoo.hardened"
+       "${T}/syslog-ng.logrotate.hardened" "${FILESDIR}/README.hardened" )
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       local f
+
+       use python && python_fix_shebang .
+
+       # remove bundled libs
+       rm -r lib/ivykis modules/afmongodb/mongo-c-driver || die
+
+       # drop scl modules requiring json
+       if use !json; then
+               sed -i -r '/cim|elasticsearch|ewmm|graylog2|loggly|logmatic/d' scl/Makefile.am || die
+       fi
+
+       # drop scl modules requiring http
+       if use !http; then
+               sed -i -r '/telegram/d' scl/Makefile.am || die
+       fi
+
+       # use gentoo default path
+       if use systemd; then
+               sed -e 's@/etc/syslog-ng.conf@/etc/syslog-ng/syslog-ng.conf@g;s@/var/run@/run@g' \
+                       -i contrib/systemd/syslog-ng@default || die
+       fi
+
+       for f in syslog-ng.logrotate.hardened.in syslog-ng.logrotate.in; do
+               sed \
+                       -e "s#@GENTOO_RESTART@#$(usex systemd "systemctl kill -s HUP syslog-ng@default" \
+                               "/etc/init.d/syslog-ng reload")#g" \
+                       "${FILESDIR}/${f}" > "${T}/${f/.in/}" || die
+       done
+
+       for f in syslog-ng.conf.gentoo.fbsd.in \
+                       syslog-ng.conf.gentoo.hardened.in \
+                       syslog-ng.conf.gentoo.in; do
+               sed -e "s/@SYSLOGNG_VERSION@/${MY_PV_MM}/g" "${FILESDIR}/${f}" > "${T}/${f/.in/}" || die
+       done
+
+       default
+       eautoreconf
+}
+
+src_configure() {
+       local myconf=(
+               --disable-docs
+               --disable-java
+               --disable-java-modules
+               --disable-riemann
+               --enable-manpages
+               --localstatedir=/var/lib/syslog-ng
+               --sysconfdir=/etc/syslog-ng
+               --with-embedded-crypto
+               --with-ivykis=system
+               --with-module-dir=/usr/$(get_libdir)/syslog-ng
+               --with-pidfile-dir=/var/run
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+               $(use_enable amqp)
+               $(usex amqp --with-librabbitmq-client=system --without-librabbitmq-client)
+               $(use_enable caps linux-caps)
+               $(use_enable dbi sql)
+               $(use_enable geoip)
+               $(use_enable http)
+               $(use_enable ipv6)
+               $(use_enable json)
+               $(use_enable mongodb)
+               $(usex mongodb --with-mongoc=system "--without-mongoc --disable-legacy-mongodb-options")
+               $(use_enable pacct)
+               $(use_enable python)
+               $(use_enable redis)
+               $(use_enable smtp)
+               $(use_enable spoof-source)
+               $(use_enable systemd)
+               $(use_enable tcpd tcp-wrapper)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       # Install default configuration
+       insinto /etc/default
+       doins contrib/systemd/syslog-ng@default
+
+       insinto /etc/syslog-ng
+       if use userland_BSD ; then
+               newins "${T}/syslog-ng.conf.gentoo.fbsd" syslog-ng.conf
+       else
+               newins "${T}/syslog-ng.conf.gentoo" syslog-ng.conf
+       fi
+
+       insinto /etc/logrotate.d
+       newins "${T}/syslog-ng.logrotate" syslog-ng
+
+       newinitd "${FILESDIR}/syslog-ng.rc" syslog-ng
+       newconfd "${FILESDIR}/syslog-ng.confd" syslog-ng
+       keepdir /etc/syslog-ng/patterndb.d /var/lib/syslog-ng
+       find "${D}" -name '*.la' -delete || die
+
+       use python && python_optimize
+}
+
+pkg_postinst() {
+       # bug #355257
+       if ! has_version app-admin/logrotate ; then
+               elog "It is highly recommended that app-admin/logrotate be emerged to"
+               elog "manage the log files.  ${PN} installs a file in /etc/logrotate.d"
+               elog "for logrotate to use."
+       fi
+
+       if use systemd; then
+               ewarn "The service file for systemd has changed to support multiple instances."
+               ewarn "To start the default instance issue:"
+               ewarn "# systemctl start syslog-ng@default"
+       fi
+}