dev-scheme/c-wrapper: fix build with >=sys-apps/texinfo-6.7
authorAkinori Hattori <hattya@gentoo.org>
Tue, 12 May 2020 14:51:28 +0000 (23:51 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Tue, 12 May 2020 14:59:24 +0000 (23:59 +0900)
Closes: https://bugs.gentoo.org/696044
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
dev-scheme/c-wrapper/c-wrapper-0.6.1-r1.ebuild
dev-scheme/c-wrapper/files/c-wrapper-texinfo-6.7.patch [new file with mode: 0644]

index 4bf3c117c0ba156019aecf79467167b8bd9d696e..a5848a95ce28433fa7e1265a4b4a4ab7879031dc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -24,6 +24,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-gentoo.patch
        "${FILESDIR}"/${PN}-glibc-2.25.patch
        "${FILESDIR}"/${PN}-info.patch
+       "${FILESDIR}"/${PN}-texinfo-6.7.patch
 )
 HTML_DOCS=( doc/${PN}-ref{e,j}.html )
 
diff --git a/dev-scheme/c-wrapper/files/c-wrapper-texinfo-6.7.patch b/dev-scheme/c-wrapper/files/c-wrapper-texinfo-6.7.patch
new file mode 100644 (file)
index 0000000..97acd86
--- /dev/null
@@ -0,0 +1,34 @@
+--- a/doc/c-wrapper-ref.texi
++++ b/doc/c-wrapper-ref.texi
+@@ -14,7 +14,7 @@
+ @direntry
+ * c-wrapper reference: (c-wrapper-refj.info). A generic wrapper for C libraries.
+ @end direntry
+-@documentencoding euc-jp
++@documentencoding UTF-8
+ @c COMMON
+ @comment %**end of header
+--- a/doc/extract
++++ b/doc/extract
+@@ -138,8 +138,6 @@
+         ((en) (filter #/^@c EN$/ #/^@c JP$/))
+         ((jp) (filter #/^@c JP$/ #/^@c EN$/))))
+-    (define outenc (if (eq? *lang* 'jp) 'euc-jp 'utf8))
+-    
+     (unless (= (length a) 1) (usage))
+     (when (eq? *lang* 'jp)
+@@ -148,9 +146,9 @@
+     (with-input-from-file (car a)
+       (lambda ()
+         (if *outfile*
+-          (with-output-to-file *outfile* do-it :encoding outenc)
++          (with-output-to-file *outfile* do-it :encoding 'utf8)
+           (let1 out (open-output-conversion-port
+-                     (current-output-port) outenc)
++                     (current-output-port) 'utf8)
+             (with-output-to-port out do-it)
+             (close-output-port out))))
+       :encoding 'euc-jp)