dev-python/construct: remove spurious test dependencies
authorVirgil Dupras <vdupras@gentoo.org>
Sun, 12 Aug 2018 00:11:13 +0000 (20:11 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Sun, 12 Aug 2018 00:14:15 +0000 (20:14 -0400)
tox and pytest-cov are not actually needed to run tests.

Package-Manager: Portage-2.3.44, Repoman-2.3.10

dev-python/construct/construct-2.8.21.ebuild

index be8e7c29cc9dbbd9bd92ba25c3dae63d0c4effc9..a856d066558a5ff6f136c17cc893b59a40b1038a 100644 (file)
@@ -18,10 +18,8 @@ IUSE="test"
 DEPEND="test? (
                dev-python/numpy[${PYTHON_USEDEP}]
                dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/tox[${PYTHON_USEDEP}]
        )"
 
 python_test() {
-       py.test -vv || die "Tests failed under ${EPYTHON}"
+       pytest -vv || die "Tests failed under ${EPYTHON}"
 }