dev-db/unixODBC: Bump to version 2.3.6
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 20 Mar 2018 09:28:39 +0000 (10:28 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 20 Mar 2018 09:30:27 +0000 (10:30 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-db/unixODBC/Manifest
dev-db/unixODBC/unixODBC-2.3.6.ebuild [new file with mode: 0644]

index b9f1ea643499feebb9772c4906b1a8283d6d8cc4..cfdb34badc893f40b4513f93c39fb7cee7f01fb3 100644 (file)
@@ -1,2 +1,3 @@
 DIST unixODBC-2.3.4.tar.gz 1830660 BLAKE2B 19b3b932e66ab2fea5645d9723592d881d86203fcc93a1a34bdc9d24fbb7fa606a0389b37988606ac60da71f378327380a32d4687dba16e784c9cdf0fd9b5fdb SHA512 34799777c95539905d4bbe60ad2b83631a31a68483b6be96dba25f80fa2fff4624ba170078097c942f2206873776d179d7d02a340598c4627f8723eb6f083a26
 DIST unixODBC-2.3.5.tar.gz 1633390 BLAKE2B f7c70740471b0c6ff298f2377a3895efbf160764adc4f607dfb65de2873ea3a39a2852399feaca50fc389875e20a10b3cd0389ba9e9f02d0548312d8063f5af5 SHA512 94b5ebb887571f4fa801ae4305cd6cb4eb0d03682fac1eb0422cdd13b046b077e60bff8286c578b0b5e291cfbc0bc8695495e39c3713858d2eeb7b38459397d5
+DIST unixODBC-2.3.6.tar.gz 1661914 BLAKE2B 75162344e2b2713ae056dae0a2c1be31994ef350b4aa3ee7ae924b17527f35e0b7c9bb5a23763ab71553ef67a025d2a6549e564507b95991d6a193e165f1e774 SHA512 6518a4169946e847dd710d54724a44d268b98954d30064eadadb703edbbeafac05bd1f42a6845c2fdcdab7ae8987800acd1a5f6b4b96de5f3c8c3e4bc370fe30
diff --git a/dev-db/unixODBC/unixODBC-2.3.6.ebuild b/dev-db/unixODBC/unixODBC-2.3.6.ebuild
new file mode 100644 (file)
index 0000000..eb5e021
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit libtool ltprune multilib-minimal
+
+DESCRIPTION="A complete ODBC driver manager"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="ftp://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+minimal odbcmanual static-libs unicode"
+
+RDEPEND="
+       || (
+               dev-libs/libltdl:0[${MULTILIB_USEDEP}]
+               >=sys-devel/libtool-2.4.2-r1[${MULTILIB_USEDEP}]
+       )
+       >=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}]
+       >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}]
+       >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       sys-devel/flex
+"
+
+MULTILIB_CHOST_TOOLS=( /usr/bin/odbc_config )
+MULTILIB_WRAPPED_HEADERS=( /usr/include/unixodbc_conf.h )
+
+multilib_src_configure() {
+       # --enable-driver-conf is --enable-driverc as per configure.in
+       myeconfargs=(
+               --sysconfdir="${EPREFIX}"/etc/${PN}
+               --disable-static
+               --enable-iconv
+               --enable-shared
+               $(use_enable static-libs static)
+               $(use_enable !minimal drivers)
+               $(use_enable !minimal driverc)
+               $(use_with unicode iconv-char-enc UTF8)
+               $(use_with unicode iconv-ucode-enc UTF16LE)
+       )
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+       einstalldocs
+
+       if use odbcmanual ; then
+               # We could simply run "make install-html" if we'd not had 
+               # out-of-source builds here.
+               docinto html
+               dodoc -r doc/.
+               find "${ED%/}/usr/share/doc/${PF}/html" -name "Makefile*" -delete || die
+       fi
+
+       use prefix && dodoc README*
+       prune_libtool_files
+}