dev-tcltk/tclreadline: fix dependency and add use tk
authorAlfredo Tupone <tupone@gentoo.org>
Tue, 26 May 2020 20:08:08 +0000 (22:08 +0200)
committerAlfredo Tupone <tupone@gentoo.org>
Tue, 26 May 2020 20:08:08 +0000 (22:08 +0200)
Closes: https://bugs.gentoo.org/724038
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-tcltk/tclreadline/tclreadline-2.3.8.ebuild

index afd3eb3663d10b609ac8cf9d7b787118c5449d24..9ebdb8473d89560f50b734488eb056280b9438b4 100644 (file)
@@ -11,16 +11,20 @@ SRC_URI="https://github.com/flightaware/tclreadline/archive/v${PV}.tar.gz
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="tk"
 
 DEPEND="dev-lang/tcl:0=
-       sys-libs/readline:0="
+       sys-libs/readline:0=
+       tk? ( dev-lang/tk:0= )"
 RDEPEND="${DEPEND}"
 BDEPEND=""
 
 src_configure() {
-       econf \
-               --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+       local myConf=--with-tcl="${EPREFIX}/usr/$(get_libdir)"
+       if ! use tk; then
+               myConf="$myConf --without-tk"
+       fi
+       econf $myConf
 }
 
 src_install() {