sci-biology/amos: Remove old
authorDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 18:45:25 +0000 (19:45 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 19:18:26 +0000 (20:18 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-biology/amos/amos-3.1.0-r2.ebuild [deleted file]
sci-biology/amos/amos-3.1.0.ebuild [deleted file]

diff --git a/sci-biology/amos/amos-3.1.0-r2.ebuild b/sci-biology/amos/amos-3.1.0-r2.ebuild
deleted file mode 100644 (file)
index 91c1f69..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit flag-o-matic python-r1
-
-DESCRIPTION="A Modular, Open-Source whole genome assembler"
-HOMEPAGE="http://amos.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
-       https://dev.gentoo.org/~soap/distfiles/${PN}-3.1.0-fix-c++14.patch.bz2"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="qt4"
-
-DEPEND="qt4? ( dev-qt/qtcore:4 )"
-RDEPEND="${DEPEND}
-       dev-perl/DBI
-       dev-perl/Statistics-Descriptive
-       sci-biology/mummer"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-gcc-4.7.patch
-       "${FILESDIR}"/${P}-goBambus2.py-indent-and-cleanup.patch
-       "${WORKDIR}"/${P}-fix-c++14.patch
-       "${FILESDIR}"/${P}-qa-Wformat.patch
-)
-
-src_configure() {
-       # prevent GCC 6 log pollution due to hash_map deprecation in C++11
-       append-cxxflags -Wno-cpp
-
-       default
-}
-
-src_compile() {
-       emake -j1
-}
-
-src_install() {
-       default
-       python_replicate_script "${ED%/}/usr/bin/goBambus2"
-}
diff --git a/sci-biology/amos/amos-3.1.0.ebuild b/sci-biology/amos/amos-3.1.0.ebuild
deleted file mode 100644 (file)
index 945ec9f..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="A Modular, Open-Source whole genome assembler"
-HOMEPAGE="http://amos.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="qt4"
-
-DEPEND="qt4? ( dev-qt/qtcore:4 )"
-RDEPEND="${DEPEND}
-       dev-perl/DBI
-       dev-perl/Statistics-Descriptive
-       sci-biology/mummer"
-
-MAKEOPTS+=" -j1"
-
-src_prepare() {
-       epatch \
-               "${FILESDIR}"/${P}-gcc-4.7.patch
-}