app-portage/pram: Bump to v8
authorMichał Górny <mgorny@gentoo.org>
Wed, 30 Oct 2019 08:29:12 +0000 (09:29 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 30 Oct 2019 08:32:55 +0000 (09:32 +0100)
This is the coolest PRam release since the last coolest release!
Now configuration can be specified via 'git config', so you can set
your preferences both globally and per-repo.

Most importantly, you can now start setting:

  git config --add pram.repo gentoo/foo

on all repos you're using PRam for, and you won't have to specify
the repo every time!

Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/pram/Manifest
app-portage/pram/pram-8.ebuild [new file with mode: 0644]

index c411a68efb34008e9b42ae30fe899bce5a41dd1d..d531fe529d78a63ff712e1f50526d6d6e2fd29a1 100644 (file)
@@ -1 +1,2 @@
 DIST pram-7.tar.gz 7471 BLAKE2B 5152002be35755031a81dbaa61118fcab0529eb9732f134b11eb2499a539e04b8b8cb6402ee3bb39c7b7c82bc918ee4fef30e247fcdba3fe32c5457cf654e257 SHA512 42e95577802d5940a0eab8da5fd36d9eb2338eccf654260364b91990a0d8de9d56cbfde767dc60bfd3c826eb45a1b0e73af717740488af0a25ff6d8c656df93e
+DIST pram-8.tar.gz 7918 BLAKE2B cc5bea629e49b229622a77c585a62710234e00ae245b68cbcfbae5be538b82752e8b2e8da5ae82f571dd4d7368ecaacd1233affe975fd9e20177122808dc39cc SHA512 bbd9e7ce3207550f1651d63a045474d90c4aaf20ab0c541b2a78e6af6351f9c7bd278b649ee57ed1b3b85cbc4f38f1b98a008e791bf9d19e4ea718892544bd46
diff --git a/app-portage/pram/pram-8.ebuild b/app-portage/pram/pram-8.ebuild
new file mode 100644 (file)
index 0000000..61c091c
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Tool to ease merging Pull Requests and git patches"
+HOMEPAGE="https://github.com/mgorny/pram"
+SRC_URI="https://github.com/mgorny/pram/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-vcs/git
+       net-misc/wget[ssl]
+       virtual/editor
+       !dev-perl/Gentoo-App-Pram"
+DEPEND="
+       test? (
+               ${RDEPEND}
+               app-crypt/gnupg
+               sys-apps/diffutils
+       )"