net-libs/libssh2: Bump to 1.9.0_p20190913 snapshot
authorMichał Górny <mgorny@gentoo.org>
Mon, 11 Nov 2019 17:59:42 +0000 (18:59 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 11 Nov 2019 18:03:18 +0000 (19:03 +0100)
Bug: https://bugs.gentoo.org/699856
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-libs/libssh2/Manifest
net-libs/libssh2/libssh2-1.9.0_p20190913.ebuild [new file with mode: 0644]

index c124fff5db14f31a416bbc1859287dcb7574ca68..c7f0147cb8647f0bed833a82cb73ee3be5a26f5c 100644 (file)
@@ -1 +1,2 @@
 DIST libssh2-1.9.0.tar.gz 888551 BLAKE2B 7bce5cd38b88654f0ca0f8b562e4bddc56346e3359e5873000cad7619607b2ec01c3945112dd8815d5de6daf650a750a4727cebe7d8996cc62f07ded06f3235f SHA512 41a3ebcf84e32eab69b7411ffb0a3b6e6db71491c968602b17392cfe3490ef00239726ec28acb3d25bf0ed62700db7f4d0bb5a9175618f413865f40badca6e17
+DIST libssh2-1.9.0_p20190913.tar.gz 467616 BLAKE2B 2df7569aa118cf339340f32a106a547265a777af5834e0e22d18ac71946747e708c48d3125489b277b5c266d66cb35e7e224425bfc6a9b2e37e5d267fd7792b2 SHA512 0e095770b059b28aebd47a1219873bfe3b6e5775bbee5d526a7b6a287090e474ceac91c03b1b8a619a2a77916a110d8d20db22edc3cbfd1772190fb394a53f8a
diff --git a/net-libs/libssh2/libssh2-1.9.0_p20190913.ebuild b/net-libs/libssh2/libssh2-1.9.0_p20190913.ebuild
new file mode 100644 (file)
index 0000000..536f4bf
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-multilib
+
+EGIT_COMMIT=336bd86d2ca4030b808d76e56a0387914982e289
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="https://www.libssh2.org"
+SRC_URI="https://github.com/libssh2/libssh2/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="gcrypt libressl mbedtls zlib"
+REQUIRED_USE="?? ( gcrypt mbedtls )"
+RESTRICT="test"
+
+RDEPEND="
+       gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+       !gcrypt? (
+               mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+               !mbedtls? (
+                       !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+                       libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+               )
+       )
+       zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+       ${RDEPEND}
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.8.0-mansyntax_sh.patch
+       "${FILESDIR}"/${PN}-1.9.0-libdir.patch
+)
+
+multilib_src_configure() {
+       local crypto_backend=OpenSSL
+       if use gcrypt; then
+               crypto_backend=Libgcrypt
+       elif use mbedtls; then
+               crypto_backend=mbedTLS
+       fi
+
+       local mycmakeargs=(
+               -DBUILD_SHARED_LIBS=ON
+               -DCRYPTO_BACKEND=${crypto_backend}
+               -DENABLE_ZLIB_COMPRESSION=$(usex zlib)
+       )
+       cmake-utils_src_configure
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       find "${ED}" -name '*.la' -delete || die
+}