dev-lua/luadoc: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 11:09:04 +0000 (12:09 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 11:24:43 +0000 (12:24 +0100)
Closes: https://bugs.gentoo.org/697354
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-lua/luadoc/luadoc-3.0.1.ebuild

index 801cfcd98671635aef2b6f7d0a1bc687e0fcbb1b..c2d1de3b9b1f1df953e40eeb765ee821d72ac5d4 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit multilib
 DESCRIPTION="LuaDoc is a documentation tool for Lua source code"
 HOMEPAGE="http://luadoc.luaforge.net/"
 SRC_URI="http://luaforge.net/frs/download.php/3185/${P}.tar.gz"
@@ -17,9 +16,9 @@ DEPEND=""
 RDEPEND=">=dev-lang/lua-5.1.3
        dev-lua/luafilesystem"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
+src_prepare() {
+       default
+
        sed -i \
                -e "s|/usr/local|\$(DESTDIR)/usr|" \
                -e "s|lib|$(get_libdir)|" \
@@ -27,11 +26,11 @@ src_unpack() {
                config || die
 
        # lua-5.1.3
-       find . -name '*.lua' | xargs sed -i -e "s/gfind/gmatch/g" || die
+       find . -name '*.lua' -exec sed -i -e "s/gfind/gmatch/g" {} + || die
 }
 
 src_install() {
-       emake DESTDIR="${D}" install || die
-       dodoc README
-       dohtml -r doc/us/*
+       default
+       docinto html
+       dodoc -r doc/us/.
 }